Problem W: 炫耀手机
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 1098 Solved: 205
Description
小F终于买到了心仪的手机,当然是华为的新款啦。小F有5个好朋友,她把新买的手机拿给朋友们看。手机就在她们手中传递了。小F先把手机给某个朋友,每个朋友欣赏完手机后就把手机传给另外一个人欣赏。当然已经看过手机的人还可以继续接过来欣赏。结果经过n次传递后,手机又回到小F手中(中间过程手机也可能回到过小F手中)。你能知道传递的过程中有多少种传递方式吗?
Input
多组测试数据,每组输入一个整数n(1<=n<=20)
Output
输出传递的种数
Sample Input
2
Sample Output
5
#include<bits/stdc++.h>
using namespace std;
long long total;
int n;
void ff(long long sum,int x,int step)
{
if (step == n + 1)
{
if(x==1)total += sum;
return;
}
if (x == 2)
{
ff(sum * 4, 2, step + 1);
ff(sum, 1, step + 1);
}
if (x == 1)
{
sum *= 5;
ff(sum, 2, step + 1);
}
}
int main(void)
{
while (cin >> n)
{
total = 0;
if (n == 1) { printf("0\n");continue; }
ff(1, 1, 1);
printf("%lld\n", total);
}
return 0;
}
因为数据较小,所以直接采用递归写。
类似这种树状分类分情况的类型,直接对每种情况进行讨论的递归,不考虑时间复杂度的话,应该是种通用解法,避免了推导通式的麻烦。(树状递归(感觉很形象))
针对这题,每次传递要考虑传递者(小F和朋友)和传递对象(小F和朋友),用x来分类。
再找递归出口,只有最后一次是传给小F的才计入total中。
Tip:step表示进行到第几次传递;
sum表示这一趟的可能;