01背包(C题)

Description(C题)

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

题意:

Roy想要抢银行,给出每个银行拥有的金钱和被抓的概率,给出Roy最大能承受的被抓概率P,求Roy不被抓的前提下最多偷盗的钱财。

可以承受的最大被抓的概率为p,即:如果逃跑的概率大于1-p则符合要求

01背包问题,把每个银行的储钱量之和当成背包容量,然后概率当成价值。这里是被抓的概率,我们把他转化成不被抓的概率,然后这里的和就可以转化成乘积。
最后不被抓的概率大于P(安全概率)(p=1-p)即可将对应的所能偷到的钱财相加,计算出最大值。

代码详解

#include<iostream>
#include<cstring>
#include<iomanip>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N=10005;
double dp[N];//需要转化一下思维,正常思维会是概率做下标
struct g {
    int v;
    double c;
} a[N];
int main()
{
    int n,t;
    double p;
    cin >> t;
    while(t--)
    {
        int sum=0;
        cin >>p>> n;
        for(int i=0; i<n; i++)
        {
            cin >>a[i].v>>a[i].c;
            sum+=a[i].v;//将价值求和
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0; i<n; i++)
            for(int j=sum; j>=a[i].v; j--)//价值对应的概率储存
            {
                dp[j]=max(dp[j],dp[j-a[i].v]*(1-a[i].c));
            }
        for(int i=sum; i>=0; i--)
            if(dp[i]>1-p)
            {
                cout<<i<<endl;//找到最大价值不被抓的概率下标
                break;
            }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值