HDU2955——01背包经典题目

题目:

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 

 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

 

 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

 

Sample Input

 

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

 

 

Sample Output

 

2 4 6

 

 

这道题比较有趣,其实也是内在也还是01背包,关键是怎么找背包中的“重量”与“价值”。

一开始想着跟着题目走,金钱做“价值”,风险做“重量”,但由于是浮点数,发现很难转化也很复杂。

那么换一下呢?采用风险来作为“价值“,金钱作为”重量“,问题就比较简单了。

那么原问题一定风险下得到的最大金钱,也就转化为:从大到小遍历金钱(”重量“),只要风险(“价值”)满足条件,就可以输出。

这里在计算一定金钱(“重量”)下的最小被抓概率(“价值”)时,可以转化成计算最大逃生概率(“价值”)。这样背包的模型就已经建立起来了。

 

背包总容量:所有银行金钱总和;      重量:各个银行的金钱      价值:各个银行可以逃生的概率        

初始状态:dp[0] = 1,表示偷0金钱的情况下,逃生概率为1。其余置为0。

状态转移方程:dp[ j ] = max {   dp[ j ]   ,   dp[ j - w[ i ] ] * v[ i ]   }

 

代码:

//
//  main.cpp
//  HDU2955
//
//  Created by jinyu on 2018/7/16.
//  Copyright © 2018年 jinyu. All rights reserved.
//

#include <iostream>
#include <algorithm>
using  namespace std;

int w[100+7];
double v[100+7];
double dp[10000+77];

int main(){
    
    int T;
    scanf("%d",&T);
    while(T--){
        double P;
        int N;
        cin>>P>>N;
        P = 1-P;
        int nn = N;
        int sumW = 0;
        while(nn--){
            memset(dp, 0, sizeof(dp));
            dp[0] = 1;
            int Mj;
            double Pj;
            cin>>Mj>>Pj;
            w[N-nn-1] = Mj;
            v[N-nn-1] = 1-Pj;
            sumW += Mj;
        }
        
        for(int i = 0;i<N;i++){
            for(int j = sumW; j>=w[i];j--){
                dp[j] = max( dp[j] , dp[j-w[i]]*v[i] );
            }
        }
        
        for(int i = sumW;i>=0;i--){
            if(dp[i] >= P)
            {
                printf("%d\n",i);
                break;
            }
        }
        
    }
    
    return 0;
}

 

第一次提交时,max函数忘记写头文件,xcode居然也没报错还运行的很好,也是很神奇了......

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值