Square Coins(母函数)

题目描述

People in Silverland use square coins. Not only they have square
shapes but also their values are square numbers. Coins with values of
all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit
coins, 9-credit coins, …, and 289-credit coins, are available in
Silverland. There are four combinations of coins to pay ten credits:
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.
Your mission is to count the number of ways to pay a given amount using coins of Silverland.

输入描述

The input consists of lines each containing an integer meaning an
amount to be paid, followed by a line containing a zero. You may
assume that all the amounts are positive and less than 300.

输出描述

For each of the given amount, one line containing a single integer
representing the number of combinations of coins should be output. No
other characters should appear in the output.

Sample Input

2
10
30
0 

Sample Output:

1
4
27 

具体代码

#include <iostream>
#include<stdio.h>
const int max1=301;
using namespace std;
int a[max1],b[max1];
int main()
{
    int n;
    while( scanf("%d",&n))
    {
        if(n==0)
            break;
        for(int i=0;i<=n;i++)
        {
            a[i]=1;//初始化,可以为1
            b[i]=0;
        }//初始化
        for(int i=2;i<=17;i++)//第二个开始,1初始,最多是17次
        {
            for(int j=0;j<=n;j++)
                for(int k=0;k+j<=n;k+=i*i)//平方
            {
                b[k+j]+=a[j];//后大括号和前一个大括号相加(乘)
            }
            for(int j=0;j<=n;j++)
            {
                a[j]=b[j];
                b[j]=0;
            }
        }
        printf("%d\n",a[n]);

    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值