PAT A1044 shopping in mars

1044 Shopping in Mars (25 point(s))

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1​⋯DN​ (Di​≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题意:给出n个数,和一个数s,n个数组成一个数列,找出第一个连续元素和等于s,如果不等于s,就找第一个连续元素和大于s的子数列(这个和最接近题目给的s,也就是如果找不到s就找最接近的那个数);

输出满足条件的下标,从1开始不是从0开始算的,如样例是1-5不是0-4;

思路:因为原数列不是递增数列,所以就求出其累加数列sum,该数列是递增的

根据sum[j]-sum[i-1]=数列j到i的和,如sum[5]就是a[0]到a[5]的和,sum[2]就是a[0]到a[2]的和,所以a[3]到a[5]的和就是sum[5]-sum[2](多出的那部分),假如j==5,i==3则有3到5的和,就是sum[5]-sum[2];

根据sum[j]-sum[i-1]=s可以得到,sum[j]=s+sum[i-1];j就是我们要求的子序列的右端点;

代码:

#include<iostream>
#include<climits>
using namespace std;
const int maxn=10010;
int sum[maxn]={0};
int upper_bound(int l,int r,int x){//找到第一个大于x的sum的位置; 
	while(l<r){
		int mid=l+(r-l)/2;
		if(sum[mid]>x){
			r=mid;
		}else {
			l=mid+1;
		}
	}
	return l;
}
int main(){
	int n,s;
	scanf("%d %d",&n,&s);
	sum[0]=0;
	for(int i=1;i<=n;i++){
		scanf("%d",&sum[i]);
		sum[i]+=sum[i-1];//累加数组的写法,不需要开两个数组; 
	}
	int nears=INT_MAX;
	for(int i=1;i<=n;i++){//每个左端点都试过;
		int l=i;
		int r=upper_bound(l,n+1,s+sum[i-1]);//妈的想半天终于知道是n+1是因为累加数列比原数列个数大1,因为初始化的时候把sum[0]=0了,所以是n+1,还是左闭右闭的写法;
        //sum[j]=a[0]+...+a[j];sum[i-1]=a[0]+...+a[i-1],sum[i-1]+s(子序列)=a[0]+...+a[j];
		if(sum[r-1]-sum[l-1]==s){//找到最接近s的子数列元素和数,不等的话就是第一个大于s的子数列元素和,此时的r是第一个大于x的元素的下标,所以是r-1进行判断;
			nears=s;
			break;
		}else if(sum[r]-sum[l-1]<nears&&r<=n){//此时第一个大于s的值即为最接近s的值,所以这里是r,不是r-1;
			nears=sum[r]-sum[l-1];
		}
	}
	for(int i=1;i<=n;i++){
		int l=i;
		int r=upper_bound(l,n+1,sum[i-1]+nears);
		if(sum[r-1]-sum[l-1]==nears){
			printf("%d-%d\n",i,r-1);
		}
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值