PAT A1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题意:给两个递增数列,合并后

求该数列的中位数;

思路:说到合并就想到归并排序的归并部分;

注意:测试点6,不过是因为当其中一个数组遍历完了,可能会拿后面不属于输入的0和前面的比,导致把属于原数列的0先放到了temp数组里面,为了防止这种情况出现,可以放一个足够大的数放到数组后面,这样就能只在输入的数据里面讨论了;

测试点6的测试样例:

5 8 9 10 11 12

3 4 5 6

输出:8

代码:

	#include<iostream>
	#include<climits> 
	using namespace std;
	const int maxn=1000010;
	int n,m;
	int a[maxn];
	int merge(int a[],int L1,int R1,int L2,int R2){
		int index=0;int i=L1;int j=L2;int temp[maxn]; 
		int mid=(m+n-1)/2;//下标从0数列找中位数,mid=(长度-1)/2; 
		while(i<=mid&&j<=mid+n){
			if(a[i]<a[j])temp[index++]=a[i++];
			else temp[index++]=a[j++];
		}
		return temp[mid];
	} 
	int main(){
		scanf("%d",&n);
		int i;
		for(i=0;i<n;i++)scanf("%d",&a[i]);
		scanf("%d",&m);
		for(i=n;i<n+m;i++)scanf("%d",&a[i]);
		a[n+m]=INT_MAX;//设置一个边界,在定义的数组内讨论,防止其中一个数组走完了,拿后面不属于输出的0跟前面的比; 
		int result=merge(a,0,n-1,n,n+m+1);
		printf("%d",result);
		return 0;
	}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值