PAT 甲级/乙级 A1074/B 1025 Reversing Linked List

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

题意(样例分析):给出一个头结点为00100,一共有6个结点,然后每4个结点,链表反转一次如

1->2->3->4->...,每4个反转一次就变成4->3->2->1...,最后不足4个不用反转;

思路:

        因为地址的5位数可以用静态链表,遍历链表给其标上序号,后根据序号从小到大排序,就可以使空间上不连续的结点在数组上连续,还可以筛出无效结点,给链表分组,每k个分成一组,遍历这些小组,当然不要忘记当遍历到最后一个小组的时候,判断其是否有除分了组的结点外,有无没有分组的结点,即不够k个而不能成一组的结点,这些结点不需要反转。

代码:

        

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=100010;
struct Node{
	int data;
	int next=-1;
	int address;//有排序必有address;
	int order=maxn; 
} node[maxn];
bool cmp(Node a,Node b){
	return a.order<b.order;//按标记顺序排序,让内存上不连续的结点在数组下标连续,并晒出无效结点; 
}
int main( ){
	int head,n,k;
	cin>>head>>n>>k;
	int id,data,next;
	for(int i=0;i<n;i++){//建立结点; 
		cin>>id>>data>>next;
		node[id].address=id;
		node[id].data=data;
		node[id].next=next;
	}
	int p=head,cnt=0;
	while(p!=-1){//遍历链表,并标记链表结点,为排序作准备; 
		node[p].order=cnt++;
		p=node[p].next;
	}
	sort(node,node+maxn,cmp);
	n=cnt;
	for(int i=0;i<n/k;i++){//遍历链表可分组(n/k向下取整,所以组内不够k,暂时不会遍历); 
		for(int j=(i+1)*k-1;j>i*k;j--){
			printf("%05d %d %05d\n",node[j].address,node[j].data,node[j-1].address);
			//虽然排序后排在了一起,但是各个结点的next域是没变的,所以不要用next域遍历; 
		}
		//最后一个结点作特殊处理;
		printf("%05d %d ",node[i*k].address,node[i*k].data);
		if(i<n/k-1){//不是可分组的最后有一块; 
			printf("%05d\n",node[(i+2)*k-1].address);
		}else {//是可分组的最后一块; 
			if(n%k==0){//判断除了可分小组还有没有其他结点; 
				printf("-1\n");
			}else {
			printf("%05d\n",node[(i+1)*k].address);
			for(int i=n/k*k;i<n;i++){
				printf("%05d %d ",node[i].address,node[i].data);
				if(i==n-1)printf("-1\n");
				else 	  printf("%05d\n",node[i].next);
				}								
			}
		} 
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值