PAT 甲级 A1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题意:给出n(5)个顶点,m(6)条边,给出起点和终点的编号

        给出n个顶点的点权

        给出m条边的端点(无向图)和边权

求最短路径数和最短路径中的最大点权和。

思路:因为是无负权无向图,可以用Dijkstra算法求出最短路径,用num存储从起点到某点的路径个数,用w来存储从起点到某点的最大点权数,前者只要有u到v的新路,最短路径的个数就增加,点权则需要和原来的w判断才决定要不要更新。

代码:
 

#include<iostream>
#include<algorithm>
#include<cstring> 
using namespace std;
const int maxn = 1010;
const int INF = 1 << 30 - 1;
int n, m, st, ed;
int G[maxn][maxn];//各点的边权; 
int weight[maxn];//各点的点权; 
int w[maxn], num[maxn], d[maxn];//起点到某点的最大点权和, 存放起点到某点的最多路径数, 起点到某点的最小距离;
bool vis[maxn] = {false};//防止顶点重复访问,已访问的结点的值是最优解; 



void Dijkstra(int st) {
	fill(d, d + maxn, INF);//没有占领其他城市, 因此其他城市的最短距离设为INF;
	memset(num, 0, sizeof(num));
	memset(w, 0, sizeof(w));
	//起点初始化!; 
	d[st] = 0;//占领初始城市;
	num[st] = 1;
	w[st] = weight[st];
	
	for(int i = 0 ; i < n; i++) {//遍历所有结点,让所有结点都找到最优解; 
		int u = -1, MIN = INF;
		for(int j = 0; j < n; j++) {
			if(vis[j] == false && d[j] < MIN) {//在开放城市里面找距离最短且没访问过的城市; 
					u = j;
					MIN = d[j];//找到距离最小的城市; 
				}
			}
			if(u == -1) return ;//剩下的顶点没有和起点连通;
			vis[u] = true;//去到最短距离的城市u; 
			for(int v = 0; v < n; v++) {// 优化U的邻居; 
			
			//初始化不用管这么多,路程最小就行,但是优化就需要对比; 
				if(vis[v] == false && G[u][v] != INF) {//优化其邻居;
				
					//d[v]的值就是在这一步初始化的,从INF变成最短路径和最短路径被优化; 
					if(d[u] + G[u][v] < d[v]) {
						d[v] = d[u] + G[u][v];
						w[v] = w[u] + weight[v];
						num[v] = num[u];//去v的城市个数应该等于去u的城市个数,初始化; 
					}else if(d[u] + G[u][v] == d[v]) {
						if(w[u] + weight[v] > w[v]) {
							w[v] = w[u] + weight[v];
						}
						num[v] += num[u];//又有其他的u可以到v,路径增加,只要有新路能去到v路径都会增加; 
					}
				}
			}
		}
	} 

 
int main () {
	scanf("%d %d %d %d", &n, &m, &st, &ed);//顶点个数,边的个数,起点编号和终点编号;
	for(int i = 0; i < n; i++) {
		scanf("%d",&weight[i]);//每个结点的点权; 
	} 
	fill(G[0], G[0] +maxn*maxn, INF);//一定要记得初始化图,限制图; 
	for(int i = 0; i < m; i++) {
		int u, v, w;
		scanf("%d %d %d", &u, &v, &w);
		G[u][v] = w;
		G[v][u] = w;//连通图; 
	}
	Dijkstra(st);
	printf("%d %d", num[ed], w[ed]);
	return 0; 
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值