浙大数据结构05-树9 Huffman Codes_哈夫曼树

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

结尾无空行

Sample Output:

Yes
Yes
No
No

结尾无空行

STL优先队列解法:

#include <bits/stdc++.h>
using namespace std;
priority_queue<int,vector<int>,greater<int> >q; //优先队列,最小堆
unordered_map<char,int> mapp;    // 散列表O(1)查找
int n,m,WPL=0;
int cmp(string &a,string &b)
{
    return a.size() < b.size();
}
// 判断是否为前缀
int isPrefix(string code[])
{
    // 按字符串长度从小到大排序
    sort(code,code+n,cmp);
    for(int i=0; i<n; i++)
    {
        for(int j=i+1; j<n; j++) // 查找之后全部字符
        {
            // 如果短字符串与长字符串截取相同长度相等,即为前缀
            if(code[j].substr(0,code[i].size()) == code[i])
                return 1;
        }
    }
    return 0;
}
int main()
{
    cin.tie(0);
    cout.tie(0);
//    freopen("C:/Users/zhaochen/Desktop/input.txt", "r", stdin);
    cin>>n;
    for(int i=0; i<n; i++)
    {
        char ch;
        int frequency;
        cin>>ch>>frequency;
        mapp[ch] = frequency;
        q.push(frequency);
    }
    while(q.size() > 1)
    {
        // 取出两个最小的元素
        int x = q.top();
        q.pop();
        int y = q.top();
        q.pop();
        q.push(x+y);
        WPL += x+y;
        // 因为所有叶结点的权值加起来等于根节点,所以WLP也等于所有非叶结点的权值之和
    }
    cin>>m;
    while(m--)
    {
        int res = 0;
        string code[64];
        char ch;
        for(int i=0; i<n; i++)
        {
            cin>>ch>>code[i];
            res += code[i].size()*mapp[ch]; // 长度*频率的总和
        }
        if(res != WPL || isPrefix(code))
        {
            if(m==0)
                cout<< "No";
            else
                cout<< "No"<< endl;
        }
        else
        {
            if(m==0)
                cout<< "Yes";
            else
                cout<< "Yes"<< endl;
        }
    }
    return 0;
}

手动建哈夫曼树:

#include <bits/stdc++.h>
#define x first
#define y second
using namespace std;
typedef long long ll;
unordered_map<char,int>mapp;    // 散列表O(1)查找
typedef struct Tnode* HuffmanTree;
struct Tnode
{
    int weight;
    HuffmanTree left,right;
};
int N,WPL=0;
int heapsize=0;
int heap[64]= {0};  // 最小堆
void Insert(int x)  // 在最小堆中插入x
{
    if(heapsize > 64)
        return;
    int i=++heapsize;
    for(; heap[i/2] > x; i/=2)
    {
        heap[i] = heap[i/2];
    }
    heap[i] = x;
}
int deleteMin()
{
    int top=heap[1];
    int last=heap[heapsize--];
    int parent,child;
    for(parent=1; parent*2<=heapsize; parent=child) // 不要写parent*=2
    {
        child=parent*2;
        if(child < heapsize && heap[child+1] < heap[child])
        {
            child++;
        }
        if(last < heap[child])
        {
            break;
        }
        heap[parent] = heap[child];
    }
    heap[parent] = last;
    return top;
}
HuffmanTree creatANode()
{
    HuffmanTree t = (HuffmanTree)malloc(sizeof(struct Tnode));
    t->left = NULL;
    t->right = NULL;
    t->weight = 0;
    return t;
}
int check()
{
    HuffmanTree root = creatANode();
    int res=0,flag=1;
    for(int i=0; i<N; i++)  // N个结点
    {
        HuffmanTree cur = root;
        char ch;
        string code;
        cin>>ch>>code;
        if(flag)
        {
            for(int j=0; j<code.size(); j++)
            {
                if(code[j]=='0')
                {
                    if(cur->left == NULL)
                    {
                        cur->left = creatANode();
                    }
                    cur = cur->left;
                }
                else
                {
                    if(cur->right == NULL)
                    {
                        cur->right = creatANode();
                    }
                    cur = cur->right;
                }
                if(cur->weight != 0)
                {
                    flag=0;
                }
            }
            if(cur->left || cur->right)
            {
                flag=0;
            }
            cur->weight = mapp[ch];
            res += cur->weight*code.size();
        }
    }
    if(res != WPL)
    {
        flag=0;
    }
    return flag;
}
int main()
{
//    system("chcp 65001");
    cin.tie(0);
    cout.tie(0);
//    freopen("C:/Users/zhaochen/Desktop/input.txt", "r", stdin);
    heap[0] = -1;
    cin>>N;
    for(int i=0; i<N; i++)
    {
        char ch;
        int frequency;
        cin>>ch>>frequency;
        mapp[ch]=frequency;
        Insert(frequency);
    }
    while(heapsize > 1)
    {
        int left = deleteMin();
        int right = deleteMin();
        Insert(left+right);
        WPL += left+right;
    }
    int M;
    cin>>M;
    while(M--)
    {
        if(check())
        {
            if(M == 0)
                cout<< "Yes";
            else
                cout<< "Yes"<< endl;
        }
        else
        {
            if(M == 0)
                cout<< "No";
            else
                cout<< "No"<< endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值