IDA*_DFS

链接:3134 -- Power Calculus

 

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x × xx3 = x2 × xx4 = x3 × x, …, x31 = x30 × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2 = x × xx3 = x2 × xx6 = x3 × x3, x7 = x6 × xx14 = x7 × x7, x15 = x14 × xx30 = x15 × x15, x31 = x30 × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x8 = x4 × x4, x10 = x8 × x2, x20 = x10 × x10, x30 = x20 × x10, x31 = x30 × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2 = x × xx4 = x2 × x2, x8 = x4 × x4, x16 = x8 × x8, x32 = x16 × x16, x31 = x32 ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer nn is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12
#include <iostream>
using namespace std;
int n;
int a[1024] = {0};
int dfs(int cur, int depth)
{
    if (cur == depth)
    {
        if (a[cur] == n)
            return 1;
        else
            return 0;
    }
    if (a[cur] << (depth - cur) < n) // 剪枝,如果剩下的步骤都是倍增还达不到
        return 0;
    for (int i = 0; i <= cur; i++) // 通过先前的值构造下一步的值
    {
        a[cur + 1] = a[cur] + a[i];
        if (dfs(cur + 1, depth))
            return 1;
        a[cur + 1] = a[cur] - a[i];
        if (dfs(cur + 1, depth))
            return 1;
    }
    return 0;
}
int main()
{
    // freopen("C:/Users/zhaochen/Desktop/input.txt", "r", stdin);
    cin.tie(0);
    cout.tie(0);
    a[0] = 1; // 从1开始
    while (cin >> n && n)
    {
        for (int depth = 0;; depth++) // 尝试计算用depth步从1得到n
        {
            if (dfs(0, depth))
            {
                cout << depth << endl;
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值