PTA-1015

PTA-1015

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes

题目大意
判断某数n以及在d进制下的反转数是否都为素数。

解答:

获取反转数:先将数字转化成字符串,再从后往前转化成整数值即反转数(反转数只需要反过来)
NOTE:这里直接不能用to_string()函数直接转化为字符串,因为这里转化忽略了进制转化,4137只有只有10进制时才能直接转化,其他进制不行

#define  _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include<cmath>

using namespace std;
bool isPrime(int N) {
    if (N <= 1) return false;
    for (int i = 2; i < N; i++)
        if (N % i == 0) return false; //取余为0即能被整除
    return true;
}
int transt(string a, int b) {
    int sum = 0;
    for (int i = a.size() - 1, base = 1; i >= 0; i--, base *= b) {
        sum += (a[i]-'0')* base;
    }
    return sum;
}
int main() {
    int N, D;
    while (1) {
        cin >> N >> D;
        if (N < 0) break;
        if (!isPrime(N)) cout << "No\n";
        else {
            //数字转化成字符串
            string N0 = "";
            while (N != 0) {
                N0 += ('0' + N % D);
                N /= D;
            }
            int value = transt(N0, D);
            if (isPrime(value)) cout << "Yes\n";
            else cout << "No\n";
        }
    }
    return 0;
}
//尝试直接调用库函数转化为字符串
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值