PTA A1015

A1015 Reversible Primes (20 分)

题目内容

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10
​5
​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

单词

reversible

英 /rɪ'vɜːsɪb(ə)l/ 美 /rɪ'vɝsəbl/

n. 双面布料
adj. 可逆的;可撤消的;可反转的

Prime

n. (美、法)普赖姆(人名)
adj. (prime) 主要的,首要的;最好的;典型的;最适宜的;素数的

n. (prime) 盛年,鼎盛时期

v. (prime) 使准备好

题目分析

弄清楚题目意思(这是我目前最大的困难之一,英文真的很难搞啊),这道题目还是很简单的,一是如何判断一个数是不是质数,而是如何计算出根据机制翻转后的数,由于之前做过一道和进制有关的题,所以做起来感觉没什么困难,对了,1不是质数,>_<。

具体代码

#include<stdio.h>
#include<stdlib.h>

int is_prime(int n)
{
    if(n==1)
    return 0;
    for (int i = 2; i < n; i++)
    {
        if (n%i == 0)
            return 0;
    }
    return 1;
}

int main(void)
{
    while (1)
    {
        int n, radix, rn = 0;
        scanf("%d", &n);
        if (n < 0)break;
        else
        {
            scanf("%d", &radix);
            if (is_prime(n))
            {
                while (n != 0)
                {
                    int m = n % radix;
                    rn = rn * radix + m;
                    n /= radix;
                }
                if (is_prime(rn))
                {
                    printf("Yes\n");
                }
                else
                    printf("No\n");
            }
            else printf("No\n");
        }
    }
    system("pause");
}

转载于:https://www.cnblogs.com/z-y-k/p/11565662.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值