统计最大数出现次数 (20 分)

编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。

输入格式:

在一行中输入待统计的整型数,各个数可以以一个或多个空格或回车分隔,以0结束。

输出格式:

以两行输出: 第一行格式:The largest number is 最大数 第二行格式:The occurrence count of the largest number is 出现次数

输入样例:

在这里给出一组输入。例如:

3 5 2 5 5 5 0

输出样例:

在这里给出相应的输出。例如:

The largest number is 5
The occurrence count of the largest number is 4

 

import java.util.Scanner;
public class Main {
  public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
        int number, max;
        number = input.nextInt();//先输入一个数
        max = number;//假设此数为最大
      int x=0;//用来计数
        while (number != 0) {//只要不为0就继续输入
            number = input.nextInt();
            if (number > max)//如果有数比当前max大,则置换,并将x置为0
                 {max = number;x=0;}
            else if(max==number) x++;//否则相等的话就++
        }
        System.out.println("The largest number is " + max);
        System.out.printf("The occurrence count of the largest number is %d",x+1);//输出和x相等的数及其本身
     }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星河欲转。

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值