【PTA】统计最大数出现次数

编写程序读取一系列整数,找出它们的最大数,然后计算该数的出现次数,假定输入以0结束。

输入格式:

在一行中输入待统计的整型数,各个数可以以一个或多个空格或回车分隔,以0结束。

输出格式:

以两行输出:
第一行格式:The largest number is 最大数
第二行格式:The occurrence count of the largest number is 出现次数

输入样例:

在这里给出一组输入。例如:

3 5 2 5 5 5 0

输出样例:

在这里给出相应的输出。例如:

The largest number is 5
The occurrence count of the largest number is 4
import java.util.*;

public class Main{
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int n;
        int max=-1;
        int count=1;
        do {
            n=scanner.nextInt();
            if (max<n) {
                max = n;
                count=1;
            }
            else if (max==n)count++;
        }while (n!=0);
        System.out.println("The largest number is "+max);
        System.out.println("The occurrence count of the largest number is "+count);

    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ོ栖落

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值