匈牙利算法(Asteroids [POJ-3041])最小点覆盖

匈牙利算法

匈牙利算法用来解决二分图中的最大匹配数,最小点覆盖,最大独立集等问题,其中这几个问题有着这样的关系:

1.最大匹配数 = 最小点覆盖数。
2.最大独立集数 = 顶点数 - 最大匹配数。

算法具体实现是基于增广路定理:一条增广路,交换匹配边和非匹配边,可以得到一个更大的匹配。

算法基本步骤

1.从左边开始,依次挑选未匹配点进行搜索,寻找增广路。
2.如果搜索到未匹配点则说明增广路找到,匹配边数加一,交换匹配边和非匹配边。
3.直至搜完为止。

例题 Asteroids [POJ-3041]

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

在此附上我的AC代码:

#include<iostream>
#include<cstring>
using namespace std;

int maze[600][600];//邻接矩阵存图。
int n, k, x, y;
int vis[10000];//是否在增广路里面。 
int match[10000];//匹配边。

bool dfs(int x)
{
	for(int y=1;y<=n;y++)
	{
		if(vis[y] || !maze[x][y]) continue;
		vis[y] = 1;
		if(!match[y] || dfs(match[y]))
		{
			match[y] = x;
			return true;
		}
	}
	return false;
}

int main()
{
	cin >> n >> k;
	for(int i=1;i<=k;i++){
		scanf("%d%d", &x, &y);
		maze[x][y] = 1;
	}
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		memset(vis, 0, sizeof(vis));
		if(dfs(i)) ans++;
	}
	printf("%d", ans);
	return 0;
 } 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值