HDOJ 1003 Max Sum 超详细

HDOJ 1003 Max Sum

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence.
For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. 
Then T lines follow, each line starts with a number N(1<=N<=100000), 
then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case.
The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence,
 the end position of the sub-sequence. If there are more than one result, 
 output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

题意简单来说就是找一个序列的最大子序列和,给定序列a [1],a [2],a [3] … a [n],计算子序列的最大和。 例如,给定(6,-1,5,4,-7),此序列中的最大和为6(-1)5 4 = 14。
最大子序列和分析图

#include<stdio.h>

int main(void)
{
    int t, i;
    scanf("%d", &t);
    for (i = 1; i <= t; i++)
    {
        int n, j, a;
        int maxsum = -1001, start = 0, end = 0, sum = 0, temp = 1;
        //题目上说测试数据范围是-1000-1000所以数列最大总和初始化为-1001绝对没问题。
        //题目上数列是从1开始下标的所以temp初始化为1.temp用于临时记录相关元素下标。
        scanf("%d", &n);
        for (j = 1; j <= n; j++)
        {
            scanf("%d", &a);
            sum += a;//计算当前数列总和
            if (sum > maxsum)//发现总和为更大的数列
            {
                start = temp;//记录当前和为最大的子序列开始与结束的下标位置
                end = j;
                maxsum = sum;//存储当前总和为最大的子序列
            }
            if (sum < 0)//发现导致序列和为负数的子序列
            {
                sum = 0;//当前数据列和假定为0,寻找下一个正数元素,也就是你建立和为正数的元素子序列
                temp = j + 1;//丢弃此序列前的所有元素,记录位置
            }
        }
        printf("Case %d:\n%d %d %d\n", i, maxsum, start, end);
        if (i != t)//按题目要求格式输出
            printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值