HDOJ 1004 Let the Balloon Rise 超详细

HDOJ 1004 Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. 
But to tell you a secret, the judges' favorite time is guessing the most popular problem. 
When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed.
 The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. 
It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

找出每组测试数据中出现次数最多的字符串并输出。
解法一
用链表,每次出现一个新的字符串那就创建一个新的链表节点,最后遍历链表,输出那个统计数最多的链表节点元素就好了。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

struct Node
{
    char color[20];
    int count;
    struct Node* next;
};

int mygets(char*);
/*c11标准委员会把gets函数从c语言标准库删除了。
这个是我自己模仿gets函数写的一个临时字符串输入函数,
可以简单的代替一下那个不幸的gets函数*/

int main(void)
{
    int n;
    char in_color[20];
    int flag;
    while (scanf("%d", &n) && n != 0)
    {
        flag = 1;
        struct Node* head = NULL, * pointer;
        while (n--)
        {
            if (flag)
            {
                getchar();//处理输入完数字后留在缓冲区的那个换行
                flag = 0;
            }
            mygets(in_color);
            if (head == NULL)
            {
                //创建链表
                head = (struct Node*)malloc(sizeof(struct Node));
                strcpy(head->color, in_color);
                head->count = 1;
                head->next = NULL;
            }
            else
            {
                pointer = head;
                while (1)
                {
                    if (strcmp(pointer->color, in_color) == 0)
                    {
                        pointer->count++;//如果是已有字符串那么统计数递增
                        break;//结束循环不执行下面的代码
                    }
                    if (pointer->next != NULL)
                        pointer = pointer->next;
                    else
                    {
                        //发现新的字符串,创建新的链表节点存储
                        pointer->next = (struct Node*)malloc(sizeof(struct Node));
                        strcpy(pointer->next->color, in_color);
                        pointer->next->count = 1;
                        pointer->next->next = NULL;
                    }
                }
            }
        }
        char strmax[20];
        int countmax = 0;
        struct Node* p = head;
        while (p)//遍历链表找目标字符串
        {
            if (p->count > countmax)
            {
                strcpy(strmax, p->color);//拷贝存入strmax里
                countmax = p->count;
            }
            p = p->next;
        }
        printf("%s\n", strmax);
        flag = 1;
        p = head;
        while (p)//申请内存空间后不要忘了释放哦
        {
            p = head;
            head = p->next;
            free(p);
            p = head;
        }
    }

    return 0;
}

int mygets(char* str)
{
    char* p = str;
    int i = 0;
    while ((*(p + i) = getchar()) != '\n')
        i++;
    *(p + i) = '\0';
}

解法二
用数组进行统计

#include<stdio.h>
#include<string.h>

int main(void)
{
    char color[1001][25];
    int max, count[1001], i, j, n, k;
    while (scanf("%d", &n) && n != 0)
    {
        for (i = 0; i < n; i++)
            scanf("%s", &color[i]);//把字符串存进数组
        for (i = 0; i < n; i++)
            count[i] = 0;
        for (i = 0; i < n; i++)
            for (j = 0; j < n; j++)
                if (strcmp(color[i], color[j]) == 0)//简单的俩俩比对
                    count[i]++;//统计出现次数
        max = 0, k = 0;
        for (i = 0; i < n; i++)//经典的找最大
            if (max < count[i])
            {
                max = count[i];
                k = i;
            }
        printf("%s\n", color[k]);
    }
    return   0;
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值