HDOJ 1062 Text Reverse 超详细

HDOJ 1062 Text Reverse

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, 
you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

**
Output**

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m'I morf .udh
I ekil .mca

Sample Output

hello world!
I'm from hdu.
I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T,
 then you may use gets() to read a line and process it.

题意就是单词翻转输出,后面还给了提示:请记住,在整数T后面使用getchar()读取’\ n’,然后可以使用gets()读取一行并进行处理。

#include<stdio.h>
#include<string.h>

int mygets(char* str);
//gets函数已经不是标准库函数,所以自定义一个简单模仿gets的函数
int main()
{
    int n;
    char str[1000];
    while (scanf("%d", &n) != EOF)
    {
        getchar();
        int len, i, r, f = -1;
        while (n--) 
        {
            mygets(str);
            len = strlen(str);
            for (i = 0; i <= len; i++) 
                if (str[i] == ' ' || i == len)
                {
                	/*碰上空格或者字符串结尾,
                	也就是每次发现一个单词就来一次倒叙输出*/
                    for (r = i - 1; r >= 0 && r != f; r--)
                        putchar(str[r]);
                    f = i;//记录上一个单词点
                    if (i != len)//补上单词间的空格
                        putchar(' ');
                }
            printf("\n");
        }
    }
    return 0;
}

int mygets(char* str)
{
    int i = 0;
    while ((*(str + i) = getchar()) != '\n')
        i++;
    *(str + i) = '\0';
    return i;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值