HDOJ 1094 A+B for Input-Output Practice (VI)超详细

HDOJ 1094 A+B for Input-Output Practice (VI)

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains multiple test cases, and one case one line. Each case starts with an integer N,
 and then N integers follow in the same line.

Output

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
15

简单循环加就可以了。主要考的就是多组输入这题。

#include<stdio.h>

int main(void)
{
    int n;
    int a, b;
    while (scanf("%d", &n) != EOF)
    {
        b = 0;//不要忘记这个初始化。每组测试数据都需要初始化的
        while (n--)
        {
            scanf("%d", &a);
            b += a;
        }
        printf("%d\n", b);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值