03-树3 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


                                                                        Figure 1

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

结尾无空行

Sample Output:

3 4 2 6 5 1

结尾无空行

#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>
#include <string.h>

typedef int ElementTypeTree;
typedef struct TreeNode * BinTree;
struct TreeNode{
    ElementTypeTree Element;
    BinTree Left;
    BinTree Right;
};
typedef BinTree ElementTypeStack;
struct StackNode{
    ElementTypeStack Element;
    struct StackNode * Next;
};
typedef struct StackNode * Stack;
Stack CreateStack()
{
    Stack stack=(Stack)malloc(sizeof(struct StackNode));stack->Next=NULL;
    return stack;
}
void Push(ElementTypeStack element,Stack stack)
{
    Stack temp=(Stack)malloc(sizeof(struct StackNode));
    temp->Element=element;
    temp->Next=stack->Next;
    stack->Next=temp;
}
ElementTypeStack Pop(Stack stack)
{
    ElementTypeStack ret;
    Stack temp=stack->Next;
    stack->Next=temp->Next;
    ret=temp->Element;
    free(temp);
    return ret;
}
BinTree MyCreateTree()
{
    int N,v;
    scanf("%d",&N);
    char operation[5],prev[5]={'\0'};
    BinTree tree=NULL,temp;
    Stack stack=CreateStack();
    BinTree root;
    bool flag=true;
    for(int i=1;i<=2*N;i++){
        scanf("%s",operation);
        if(strcmp(operation,"Push")==0){
            scanf("%d",&v);
            temp=(BinTree)malloc(sizeof(struct TreeNode));temp->Left=NULL;temp->Right=NULL;
            temp->Element=v;
            Push(temp,stack);
            //储存树根
            if(flag){
                root=temp;
                flag=false;
            }
            //如果上一次的操作是Pop,那么这次Push的挂在右节点上,否则,挂在左节点
            if(strcmp(prev,"Pop")){
                if(tree==NULL){
                    tree=temp;
                }else{
                    tree->Left=temp;
                    tree=temp;
                }
            }else{
                tree->Right=temp;
                tree=temp;
            }
        }
        if(strcmp(operation,"Pop")==0){
            tree=Pop(stack);
        }
        strcpy(prev,operation);
    }
    return root;
}
void PostOrderTraversal(BinTree tree,int * pflag)
{
    if(tree){
        PostOrderTraversal(tree->Left,pflag);
        PostOrderTraversal(tree->Right,pflag);
        if(*pflag){
            printf("%d",tree->Element);
            *pflag=0;
        }else{
            printf(" %d",tree->Element);
        }
    }
}

int main()
{
    BinTree tree=MyCreateTree();
    int flag=1;
    PostOrderTraversal(tree,&flag);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值