04-树6 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

  • Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0

    结尾无空行

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

    结尾无空行

  • 分析:完全二叉树,适合用数组表示,按层序编号

  • #include <stdio.h>
    #include <stdlib.h>
    #include <stdbool.h>
    #include <math.h>
    #define MAXSIZE 1000
    
    #define Min(a,b) ( ( (a)<(b) )?(a):(b) )
    
    int A[MAXSIZE];
    int T[MAXSIZE];
    int compare(const void * a,const void * b)
    {
        return *(int*)a-*(int*)b;
    }
    int NodesLeftSubCompBST(int N)//返回左子树节点的个数。注:左子树仍是完全二叉搜索树
    {
        int H=(int) (log(N+1)/log(2));//H为除去残缺部分而成的完美二叉树的高度
        int X=N-(pow(2,H)-1);
        return pow(2,H-1)-1+Min(X,pow(2,H-1));
    }
    void FillCompleteBST(int ALeft,int ARight,int TRoot)//TRoot初始传进来0
    {
        int N=ARight-ALeft+1;
        int TLeftRoot,TRightRoot;
        if(ALeft>ARight)    return;
        int k=NodesLeftSubCompBST(N);//完全二叉搜索树只要给定节点数,结构就是确定的
        T[TRoot]=A[ALeft+k];
        TLeftRoot=2*TRoot+1;
        TRightRoot=TLeftRoot+1;
        FillCompleteBST(ALeft,ALeft+k-1,TLeftRoot);
        FillCompleteBST(ALeft+k+1,ARight,TRightRoot);
    
    }
    
    int main()
    {
        int N;
        scanf("%d",&N);
        for(int i=0;i<N;i++){
            scanf("%d",A+i);
        }
        qsort(A,N,sizeof(int),compare);
        FillCompleteBST(0,N-1,0);
        bool flag=true;
        for(int i=0;i<N;i++){
            if(flag){
                printf("%d",T[i]);
                flag=false;
            }else
                printf(" %d",T[i]);
        }
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值