04-树6 Complete Binary Search Tree (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
#include<iostream>
#include<stack>
#include<algorithm>
using namespace std;
int main(){
int N,V;
scanf("%d",&N);
int a[N+1],b[N]; //a[i]用来存储树的结点,b[i]用来存储输入的数据
for(int i=0;i<N;i++){
scanf("%d",&b[i]);
}
sort(b,b+N); //将数据从小到大排序就是完全二叉排序树的中序遍历序列
stack<int>S;
int i=1,j=0;
while(i<=N||!S.empty()){ //用中序遍历的非递归算法反向给结点赋值
while(i<=N){
S.push(i);
i=i*2;
}
if(!S.empty()){
int k=S.top();
S.pop();
a[k]=b[j++];
i=k*2+1;
}
}
for(i=1;i<=N;i++){
if(i!=1){
printf(" ");
}
printf("%d",a[i]); //a[i]的输出顺序就是层次遍历的顺序
}
return 0;
}