05-树8 File Transfer(并查集)

本文探讨了一种计算机网络架构,其中双向连接允许文件在各台电脑间传输。核心内容涉及检查文件传输可能性、网络连通性和组件划分。通过实例展示了如何使用算法判断是否能在任意两台电脑间直接传输文件,并确定网络的连通状态或组成部分。
摘要由CSDN通过智能技术生成

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.
#include <stdio.h>
#include <stdlib.h>

typedef int SetType;//为了简化,不用含有Data,Parent的结构表示集合元素了,而只用Parent表示,Data=下标+1
typedef int ElementType;
void Initialize(SetType S[],int N)
{
    int i;
    for(i=0;i<N;i++){
        S[i]=-1;
    }
}

//int FindRoot(SetType S[],ElementType X)
//{
//    int i=X-1;
//    for(;S[i]>=0;i=S[i])    continue;
//    return i;
//}
int FindRoot(SetType S[],ElementType X)//路径压缩Compression version
{
    int i=X-1;
    if(S[i]<0)  return i;
    return S[i]=FindRoot(S,S[i]+1);//返回的时候发生side effect
}
void Union(SetType S[],int root1,int root2)
{
    if(root1!=root2){
        if(S[root1]<S[root2]){
            S[root1]+=S[root2];
            S[root2]=root1;
        }else{
            S[root2]+=S[root1];
            S[root1]=root2;
        }
    }
}
void InputConnection(SetType S[],ElementType X1,ElementType X2)
{
    int root1,root2;
    root1=FindRoot(S,X1);root2=FindRoot(S,X2);
    Union(S,root1,root2);
}

void CheckConnection(SetType S[],ElementType X1,ElementType X2)
{
    if(FindRoot(S,X1)==FindRoot(S,X2))  puts("yes");
    else    puts("no");
}

void CheckNetwork(SetType S[],int N)
{
    int i,cnt;
    for(i=0,cnt=0;i<N;i++){
        if(S[i]<0)  cnt++;
    }
    if(cnt==1)  puts("The network is connected.");
    else    printf("There are %d components.\n",cnt);
}
int main()
{
    int N;
    scanf("%d",&N);
    SetType S[N];
    Initialize(S,N);
    char operation;
    do{
//        operation=getchar();
        scanf("%c",&operation);
        ElementType X1,X2;
        scanf("%d %d",&X1,&X2);
        switch(operation){
            case 'C':CheckConnection(S,X1,X2);break;
            case 'I':InputConnection(S,X1,X2);break;
            case 'S':CheckNetwork(S,N);break;
        }
    }while(operation!='S');

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值