OJ练习16(C语言):单词统计

一、题目

Description:

从键盘输入一行字符,统计其中单词的个数,各单词以空格分隔,且空格数可以是多个。

Input:

输入只有一行句子。仅有空格和英文字母构成。

Output:

单词的个数。

Sample Input:

stable marriage  problem Consists     of Matching members 

Sample Output:

7

二、代码

#include<stdio.h>
#include<string.h>
int main()
{
	/*通过统计空格来统计单词数*/
	char str[100];
	gets(str);
	int count = 0;
	for (int i = 0; str[i]!='\0'; i++)
	{
		if (str[i] == ' ' && str[i + 1] != ' ')
		{
			count++;
		}
	}
	if (str[strlen(str) - 1] == ' ') //最后一个单词后面若还有空格不统计
	{
		printf("%d", count);
	}
	else 
	{
		printf("%d", count + 1);
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值