1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K NaNNaN2 ... NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

polynomial 多项式

exponent 指数

coefficient 系数

  • 代码

    #include<iostream>
    #include<vector>
    #include<string>
    #include<math.h>
    #include<algorithm>
    #include<stack>
    using namespace std;
    
    int main(){
       int n1;
       cin >> n1;
       float c[1001]={0};
       int zhishu;
       float xishu;
       **for(int i = 0; i < n1; i ++)
       {
           cin >> zhishu >> xishu;
           c[zhishu] += xishu;
       }**
       int n2;
       cin >> n2;
       for(int i = 0; i < n2; i ++)
       {
            cin >> zhishu >> xishu;
            c[zhishu] += xishu;
       }
       int cnt = 0;
       for(int i = 0; i < 1001;i ++)
       {
           if(c[i] != 0) cnt ++; //系数不等于0
       }
       cout << cnt ;
       for( int i = 1000; i >= 0; i--)
       {
           if(c[i] != 0.0) printf(" %d %.1f", i, c[i]); //输出指数和系数
       }
    
        return 0;
    }
    
    
  • 总结

    注意这题要按照系数的由大到小排序,保留一位小数。通过这题掌握利用数组计数的方法。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值