2602 Bone Collector

题目详情:

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 130596    Accepted Submission(s): 51958

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
Author
Teddy
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1171 1003 

题目大意:

每个骨头都有价值和体积,背包容量有限,并且每一个骨头都只有一个,问在背包容量范围内如何装骨头使背包里骨头的价值最大。

 解题思路:

用DP二维数组记录当前价值最大的价值,直到遍历到最后一个元素,即为最大价值。

AC代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
class bone{
    public:
        long long int value;
        long long int place;
};
int main(){
    int n;
    cin>>n;
    while(n--){
        int num,v;
        cin>>num>>v;
        bone b[num+1];
        b[0].place=0;
        b[0].value=0;
        for(int i=1;i<=num;++i){
            cin>>b[i].value;
        }
        for(int i=1;i<=num;++i){
            cin>>b[i].place;
        }
        vector<vector<long long int>> dp(num+1,vector<long long int>(v+1,0));
        for(int i=1;i<=num;++i){
            for(int j=0;j<=v;++j){
                if(b[i].place<=j){
                    dp[i][j]=max(dp[i-1][j-b[i].place]+b[i].value,dp[i-1][j]);
                }
                else dp[i][j]=dp[i-1][j];//继承上一行
            }
        }
        cout<<dp[num][v]<<endl;
    }
    return 0;
}

对空间进行优化,二维数组变成一维数组后AC代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
class bone{
    public:
        long long int value;
        long long int place;
};
int main(){
    int n;
    cin>>n;
    while(n--){
        int num,v;
        cin>>num>>v;//num:物品个数,v:背包容量
        bone b[num+1];
        b[0].place=0;
        b[0].value=0;
        for(int i=1;i<=num;++i){
            cin>>b[i].value;
        }
        for(int i=1;i<=num;++i){
            cin>>b[i].place;
        }
        //用一维数组方法
        vector<long long int> dp(v+1,0);
        for(int i=1;i<=num;++i){
            //j表示背包容量
            for(int j=v;j>=b[i].place;--j){//没必要循环到0,体积小于背包空间肯定放不下
                dp[j]=max(dp[j-b[i].place]+b[i].value,dp[j]);
            }
        }
        cout<<dp[v]<<endl;
    }
    return 0;
}

推荐几款学习编程的网站

免费在线开发平台(LTPP在线开发平台 | LTPP宇宙文档

        探索编程世界的新天地,为学生和开发者精心打造的编程平台,现已盛大开启!这个平台汇集了近4000道精心设计的编程题目,覆盖了C、C++、JavaScript、TypeScript、Go、Rust、PHP、Java、Ruby、Python3以及C#等众多编程语言,为您的编程学习之旅提供了一个全面而丰富的实践环境。

        在这里,您不仅可以查看自己的代码记录,还能轻松地在云端保存和运行代码,让编程变得更加便捷。平台还提供了私聊和群聊功能,让您可以与同行们无障碍交流,分享文件,共同进步。不仅如此,您还可以通过阅读文章、参与问答板块和在线商店,进一步拓展您的知识边界。

        为了提升您的编程技能,平台还设有每日一题、精选题单以及激动人心的编程竞赛,这些都是备考编程考试的绝佳资源。更令人兴奋的是,您还可以自定义系统UI,选择视频或图片作为背景,打造一个完全个性化的编码环境,让您的编程之旅既有趣又充满挑战。

免费公益服务器(LTPP公益LINUX服务器分享 | LTPP宇宙文档

        作为开发者或学生,您是否为搭建和维护编程环境而困扰?现在,有一款免费的公共服务器,内置多种编程语言的编程环境,并且配备了在线版VS Code。让您可以随时随地在线写代码,无需复杂配置,专注于开发和学习。(PS:毕竟是免费公共的服务器,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费公益MYSQL(LTPP公益MYSQL分享 | LTPP宇宙文档

        作为一名开发者或学生,您是否常常为数据库环境的搭建而烦恼?是否因为预算有限而无法使用高性能的数据库服务?现在,有一款免费的MySQL服务器,专为开发者和学生量身打造,让你轻松无忧地进行开发和学习!内置在线phpmyadmin管理面板,方便用户查看数据。(PS:毕竟是免费公共的MYSQL,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费在线WEB代码编辑器(LTPP在线WEB编辑器 | LTPP宇宙文档

        无论你是开发者还是学生,编程环境的搭建和管理可能会占用你宝贵的时间和精力。现在,有一款强大的免费在线代码编辑器,支持多种编程语言,让您可以随时随地编写、调试和运行代码,提升编程效率,专注于创意和开发。

免费二维码生成器(LTPP二维码生成器 | LTPP宇宙文档

        无论是企业宣传、活动推广,还是个人信息分享,二维码都是一种快速、高效的信息传递方式。现在,有一款功能强大的二维码生成器,不仅易于使用,还具备多种便捷功能,帮助您更轻松地生成和管理二维码。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WA-自动机

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值