1372 Knight Moves

题目详情:

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18235    Accepted Submission(s): 10461


 

Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

Sample Input
 
 
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output
 
 
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1253 1072 1240 1312 1241 
题目大意:
8*8的棋盘,马从起点到终点最少要走多少步。
解题思路:
马走日,通过数组把走的方式保存下来,再BFS就可以了。
AC代码:
#include<iostream>
#include<queue>
#include<vector>
using namespace std;
int l_x[8]={-1,-1,1,1,-2,-2,2,2};
int l_y[8]={2,-2,2,-2,1,-1,1,-1};
class loaction{
    public:
        int x;
        int y;
        int steps;
};
bool limit(int x,int y){
    if(x<=0||y<=0||x>8||y>8) return 0;
    else return 1;
}
loaction BFS(int x1,int y1,int x2,int y2){
    loaction l_current,l_next;
    queue<loaction> q_1;
    vector<vector<int>> sign(10,vector<int>(10,1));//真实坐标1-8,两边都加一防止越界
    l_current.x=x1;
    l_current.y=y1;
    l_current.steps=0;
    q_1.push(l_current);
    while(!q_1.empty()){
        l_current=q_1.front();
        q_1.pop();
        for(int i=0;i<8;++i){
            l_next.x=l_current.x+l_x[i];
            l_next.y=l_current.y+l_y[i];
            if(limit(l_next.x,l_next.y)&&sign[l_next.x][l_next.y]){
                sign[l_next.x][l_next.y]=0;
                l_next.steps=l_current.steps+1;
                q_1.push(l_next);
                if(l_next.x==x2&&l_next.y==y2){
                    return l_next;
                }
            }
        }
    }
}
int main(){
    char a1,a2;
    int b1,b2;
    while(cin>>a1>>b1>>a2>>b2){
        int x1=b1;
        int y1=a1-'a'+1;//因为上面数组下标取1-8,不是从0取,所以加一
        int x2=b2;
        int y2=a2-'a'+1;//因为上面数组下标取1-8,不是从0取,所以加一
        if(x1==x2&&y1==y2){
            cout<<"To get from "<<a1<<b1<<" to "<<a2<<b2<<" takes "<<0<<" knight moves."<<endl;
            continue;
        }
        loaction judge=BFS(x1,y1,x2,y2);
        cout<<"To get from "<<a1<<b1<<" to "<<a2<<b2<<" takes "<<judge.steps<<" knight moves."<<endl;
    }
}

推荐几款学习编程的网站

免费在线开发平台(LTPP在线开发平台 | LTPP宇宙文档

        探索编程世界的新天地,为学生和开发者精心打造的编程平台,现已盛大开启!这个平台汇集了近4000道精心设计的编程题目,覆盖了C、C++、JavaScript、TypeScript、Go、Rust、PHP、Java、Ruby、Python3以及C#等众多编程语言,为您的编程学习之旅提供了一个全面而丰富的实践环境。

        在这里,您不仅可以查看自己的代码记录,还能轻松地在云端保存和运行代码,让编程变得更加便捷。平台还提供了私聊和群聊功能,让您可以与同行们无障碍交流,分享文件,共同进步。不仅如此,您还可以通过阅读文章、参与问答板块和在线商店,进一步拓展您的知识边界。

        为了提升您的编程技能,平台还设有每日一题、精选题单以及激动人心的编程竞赛,这些都是备考编程考试的绝佳资源。更令人兴奋的是,您还可以自定义系统UI,选择视频或图片作为背景,打造一个完全个性化的编码环境,让您的编程之旅既有趣又充满挑战。

免费公益服务器(LTPP公益LINUX服务器分享 | LTPP宇宙文档

        作为开发者或学生,您是否为搭建和维护编程环境而困扰?现在,有一款免费的公共服务器,内置多种编程语言的编程环境,并且配备了在线版VS Code。让您可以随时随地在线写代码,无需复杂配置,专注于开发和学习。(PS:毕竟是免费公共的服务器,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费公益MYSQL(LTPP公益MYSQL分享 | LTPP宇宙文档

        作为一名开发者或学生,您是否常常为数据库环境的搭建而烦恼?是否因为预算有限而无法使用高性能的数据库服务?现在,有一款免费的MySQL服务器,专为开发者和学生量身打造,让你轻松无忧地进行开发和学习!内置在线phpmyadmin管理面板,方便用户查看数据。(PS:毕竟是免费公共的MYSQL,任何人都能够使用,为了数据隐私和安全,请勿上传重要数据,仅用于学习)

免费在线WEB代码编辑器(LTPP在线WEB编辑器 | LTPP宇宙文档

        无论你是开发者还是学生,编程环境的搭建和管理可能会占用你宝贵的时间和精力。现在,有一款强大的免费在线代码编辑器,支持多种编程语言,让您可以随时随地编写、调试和运行代码,提升编程效率,专注于创意和开发。

免费二维码生成器(LTPP二维码生成器 | LTPP宇宙文档

        无论是企业宣传、活动推广,还是个人信息分享,二维码都是一种快速、高效的信息传递方式。现在,有一款功能强大的二维码生成器,不仅易于使用,还具备多种便捷功能,帮助您更轻松地生成和管理二维码。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WA-自动机

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值