【PAT】【简单模拟排序】1025 PAT Ranking (25 分)

题目链接:1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

// raw word:

// simultaneously同时地  College学院    locations地点

// 解题思路:

// 简单模拟排序题,将信息整合到结构体中,然后进行排序即可

// 这里用的优先队列自动排序,输出时再计算排名

// 其实将final和local排名整合到信息结构体中,设立两个vector

// 对每个local处理得到local排名后,再加入final的vector会更加简洁逻辑清晰些(可参考柳婼的题解)

 

#include <bits/stdc++.h>
using namespace std;
// 将每个考生的信息存入一个结点中
struct node
{
    string number;
    int score, lnum;
    // 定义比较方式
    bool operator<(const node &r) const
    {
        if(score != r.score)
        return score < r.score;
        else return number > r.number;
    }
};
// 分别记录分组排名,分组的上次分数
int local[105], lscore[105];
priority_queue<node> q;
int main()
{
    int n, k;
    cin >> n;
    for (int i = 1; i <= n; i++)
    {
        cin >> k;
        string name;
        int score;
        for (int j = 1; j <= k; j++)
        {
            cin >> name >> score;
            q.push((node){name, score, i});
        }
    }
// 初始化处理数据
    memset(lscore, -1, sizeof(lscore));
    int final(0), last(-1), a(0), b(0);
    printf("%d\n", q.size());
    while(!q.empty())
    {
        node t = q.top();
        q.pop();
        // final和local排名戳
        final++; local[t.lnum]++;
        // 不等时则更新
        if(t.score != last) a = final;
        if(t.score != lscore[t.lnum]) b = local[t.lnum];
        cout << t.number << " " << a << " " << t.lnum << " " << b << endl;
        // 更新上次分数记录
        last = lscore[t.lnum] = t.score;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值