【PAT】【链表遍历】1032 Sharing (25 分)

题目链接:1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

// raw word:

// sublist子表  suffix后缀

// 解题思路:

// 求后缀中第一个元素的地址,如果没有后缀的话则输出-1

// 只需要对两个链表分别遍历一遍,重复遍历到的第一个元素则是答案

#include <iostream>
#include <cstdio>
#include <map>
using namespace std;
// 结点
struct node{
    string id, next;
    char c;
};
// 对结点地址进行映射,如果地址稀疏的的话会极大节省空间
// 但是这道题n的数量级是n^5,地址是五位数,所以完全没必要,反而增加了时间和空间复杂度
// 导致最后一个测试点接近超时
map<string, int> mp; 
// 用来计数,实际上在结构体中增加flag项是更优的做法
map<string, int> cnt;
const int maxn = 1e5 + 5;
node a[maxn];
int main(){
    // 读入数据
    string s1, s2; cin >> s1 >> s2;
    int n; cin >> n;
    string ans;
    for(int i = 1; i <= n; i++){
        cin >> a[i].id >> a[i].c >> a[i].next;
        mp[a[i].id] = i; // 地址映射
    }
    // 第一次遍历
    mp["-1"] = 0;
    int u = mp[s1];
    while(u){
        ++cnt[a[u].id];
        u = mp[a[u].next];
    }
    // 第二次遍历
    u = mp[s2];
    while(u){
        if(++cnt[a[u].id] > 1){
            cout << a[u].id << endl;
            return 0;
        }
        u = mp[a[u].next];
    }
    cout << -1 << endl;
    return 0;
}

 // 参考了柳婼题解,优化后代码如下:

#include <iostream>
#include <cstdio>
using namespace std;

struct node{
    int next;
    char c;
    bool flag = 0;
};
const int maxn = 1e6 + 5;
node a[maxn];
int main(){
    int s1, s2, n; cin >> s1 >> s2 >> n;
    string ans;
    for(int id, i = 1; i <= n; i++){
        cin >> id;
        cin >> a[id].c >> a[id].next;
    }
    int u = s1;
    while(~u){
        a[u].flag = true;
        u = a[u].next;
    }
    u = s2;
    while(~u){
        if(a[u].flag){
            printf("%05d\n", u);
            return 0;
        }
        u = a[u].next;
    }
    cout << -1 << endl;
    return 0;
}

柳婼的题解:https://blog.csdn.net/liuchuo/article/details/52144527 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值