OSPF拓扑搭建

一、实验要求
在这里插入图片描述
二、相关配置
配置思路:首先先为路由器配置IP地址,用回环来模拟用户,其中R6范围内为公网(ISP),先为每个路由器配置IP地址,为每个路由器写静态路由指向R6,之后R1/4/5采用MGRE模式,R1/2/4为星型结构模式,修改接口选举优先级,设置R1为中心(主),R2,R3为从,利用OSPF协议宣告每个路由器的网段(R6范围为公网,不能宣告)使得全网可达。

拓扑搭建几相关地址规划
在这里插入图片描述
IP地址的相关配置
interface GigabitEthernet0/0/0
ip address 192.168.6.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 192.168.1.1 255.255.255.0
interface LoopBack0
ip address 1.1.1.1 255.255.255.0
在这里插入图片描述
静态路由
ip route-static 0.0.0.0 0.0.0.0 192.168.1.2
ip route-static 0.0.0.0 0.0.0.0 192.168.6.2
在这里插入图片描述
在这里插入图片描述
R1/4/5基于MGRE环境
interface Tunnel0/0/0
ip address 192.168.7.1 255.255.255.0
tunnel-protocol gre p2mp
source 192.168.1.1
ospf network-type broadcast
nhrp entry multicast dynamic
nhrp network-id 100
nhrp entry 192.168.7.3 192.168.5.1 register
在这里插入图片描述
R1/2/3基于星型环境
interface Tunnel0/0/1
ip address 192.168.8.1 255.255.255.0
tunnel-protocol gre p2mp
source 192.168.6.1
ospf network-type broadcast
nhrp entry multicast dynamic
nhrp network-id 100
nhrp entry 192.168.8.2 192.168.2.1 register
nhrp entry 192.168.8.3 192.168.3.1 registe

修改优先级,是的R1为MASTER
interface GigabitEthernet0/0/1
ip address 192.168.1.1 255.255.255.0
ospf dr-priority 2

OSPF宣告
ospf 1 router-id 1.1.1.1
area 0.0.0.0
network 1.1.1.1 0.0.0.0
network 192.168.7.0 0.0.0.255
network 192.168.8.0 0.0.0.255

基于OSPF全网可达在这里插入图片描述在这里插入图片描述

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页