题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
代码长度限制
16 KB
时间限制
200 ms
内存限制
64 MB
中文释义
这项任务非常简单:假设高速公路上有N个出口,形成一个简单的循环,你应该说出任意两个出口之间的最短距离。
输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含一个整数N(在[3105]中),后跟N个整数距离D1 D2 ⋯ DN, 迪在哪里 是第i个出口和(i+1)个出口之间的距离,DN 在第N个出口和第1个出口之间。一行中的所有数字都用空格隔开。第二行给出一个正整数M(≤104),后面有M条线路,每条线路包含一对出口编号,前提是出口编号从1到N。保证总往返距离不超过107。
输出规格:
对于每个测试用例,以M行打印结果,每行包含相应给定出口对之间的最短距离。
思路
类比前缀和的思想,arr[i]存储1号点到i号点的距离,sum用来存储一圈的距离和。这样两点间距离就变成了arr[e]-arr[s](要保证s<e) 与 sum-(arr[e]-arr[s])
AC代码
#include<bits/stdc++.h>
using namespace std;
int n;
int Sum=0;
vector<int>arr;
int main(){
cin>>n;
arr.resize(n+2);
arr[1]=0;
for(int i=2;i<=n+1;i++){
int t;
cin>>t;
Sum+=t;
arr[i]=arr[i-1]+t;
}
int m;
cin>>m;
while(m--){
int s,e;
cin>>s>>e;
if(s>e)swap(s,e);
cout<<min(arr[e]-arr[s],Sum-(arr[e]-arr[s]))<<endl;
}
return 0;
}