7-2 实验9_3_字母统计 (100分)

7-2 实验9_3_字母统计 (100分)

任意给定一个字符串,字符串中包含除了空格、换行符之外的的任意字符。你的任务是统计出现在该字符串中的各字母(即“A—Z”,“a—z”)的个数(区分大小写)。

输入格式:
一个长度不超过100的非空字符串。字符串中不会出现空格、换行符。

输出格式:
字符串中出现的字母的统计信息,每个字母的统计信息占一行,按照字母的ASCII码的顺序输出。。

输入样例:

AAAsdf&^%DF879as

输出样例:
注意单词“time”不论单复数,一律输出复数形式“times”

The character A has presented 3 times.
The character D has presented 1 times.
The character F has presented 1 times.
The character a has presented 1 times.
The character d has presented 1 times.
The character f has presented 1 times.
The character s has presented 2 times.
#include<stdio.h>

int main() {
    char a[110];
    int c[150]={0};
    scanf("%s",a);
    int i=0;
    while (a[i]!='\0'){
        if ((a[i]>='A'&&a[i]<='Z')||(a[i]>='a'&&a[i]<='z')){
            c[a[i]]++;
        }
        i++;
    }
    for (int j = 0; j <150 ; j++) {
        if (c[j]!=0){
            printf("The character %c has presented %d times.\n",j,c[j]);
        }
    }
    return 0;
}
  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值