7-1 实验9_1_括号匹配 (100分)

7-1 实验9_1_括号匹配 (100分)

任意给定一个字符串,字符串中包含除了空格、换行符之外的任意字符。你的任务是检测字符串中的小括号是否配对,即“(”与“)”是否配对。如字符串“((a+b)* (c+d))”中小括号是配对的,而“((a+b)*) c+d))”则不配对。

程序运行效果:

Sample 1: ((a+b)*(c+d)) ↙

parentheses match!↙

Sample 2:

((a+b)*)c+d)) ↙

parentheses do not match!↙

输入格式:
一个长度不超过100的非空字符串,该字符串中不会出现空格、换行符。

输出格式:
见程序运行效果。

输入样例:

((a+b)*(c+d)) 

输出样例:

parentheses match!
#include<stdio.h>

int main() {
    char a[1000];
    scanf("%s",a);
    char char1='(',char2=')';
    int i=0,c=0;
    while (a[i]!='\0'){
        if (a[i]==char1){
            c++;
        }
        if (a[i]==char2){
            c--;
        }
        if (c<0){
            printf("parentheses do not match!");
            return 0;
        }
        i++;
    }
    if (c>0){
        printf("parentheses do not match!");
    }
    if (c==0){
        printf("parentheses match!");
    }
    return 0;
}
  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值