数学问题/A1049 计数字1的个数

该程序的任务是计算从1到给定正整数N之间所有数字中1的总数。例如,当N为12时,1到12中有5个1。程序通过逐位分析数字并计算每种情况下1的数量来实现这一目标。
摘要由CSDN通过智能技术生成

1049 Counting Ones

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

#include<iostream>

using namespace std;

//书P1049

//例如数字30710,从个位数往前看,个位数记为第一位,最前面一位数字为第五位
//一位一位的来取1
//第一位为0 <1,左边有四位3071,右边零位,仅在前四位为0000-3070时,第一位才可取到1,此时有3071*1种情况
//第二位为1=1,左边有三位307,右边有一位(1)前面三位000-306,右边一位可以取任意0-9 此时有307*10种情况,10是指0-9(2)当高位为307时,就一种情况

int main(){
    int n;
    cin>>n;
    int left,now,right,a=1,ans=0;
    while(n/a!=0){
        left=n/(a*10);
        now=n/a %10;
        right=n%a;
        
        if(now==0) ans+=left*a;
        else if(now==1) ans+=left*a+right+1;
        else ans+=(left+1)*a;

        a*=10;
    }
    cout<<ans<<endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值