A1102 Invert a Binary Tree 输出反转二叉树的层序和中序遍历,用的是后序遍历进行反转

1102 Invert a Binary Tree分数 25

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
#include<iostream>
#include<vector>
#include<queue>
using namespace std;

int n;

//1.先定义数 2.结果输出中序和层序遍历,模板  3.用后序遍历来反转,swap函数
//4.处理输入的字符‘-’转为-1,判断是否为根节点,不是根节点返回节点编号
//5.查找哪个为跟节点


//处理一下输出的空格
int num=0;//已输出的个数
void printf(int id){
    cout<<id;
    num++;
    if(num<n) printf(" ");
    else printf("\n");
}

struct node{//静态树
    int lchild,rchild;
}Node[11];

//中序遍历,左跟右
void inorder(int root){
    if(root==-1)return;
    inorder(Node[root].lchild);
    printf(root);    
    inorder(Node[root].rchild);
}

//层序遍历
void bfs(int root){
    queue<int> q;//注意队列里存的是地址
    q.push(root);//将根节点的地址入队
    while(!q.empty()){
        int now=q.front();//取出队列的队首元素
        q.pop();
        printf(now);
        if(Node[now].lchild!=-1) q.push(Node[now].lchild);//左子树非空
        if(Node[now].rchild!=-1) q.push(Node[now].rchild);//右子树非空
    }
}

//后序遍历 左右根,反转二叉树
void postorder(int root){
    if(root==-1)return;
    postorder(Node[root].lchild);
    postorder(Node[root].rchild);
    swap(Node[root].lchild,Node[root].rchild);//交换左右孩子
}

//将输入的字符串转为数字或节点编号,-转为-1
bool notroot[11]={false};//记录是否不是根节点,初始输入的时候都是根节点
int strtonum(char c){
    if(c=='-')return -1;
    else{
        notroot[c-'0']=true;//不是根节点
        return c-'0';//返回节点编号
    }
}

//寻找根节点
int findroot(){
    for(int i=0;i<n;i++){
        if(notroot[i]==false){
            return i;//返回根节点
        }
    }
}

int main(){
    cin>>n;
    char lchild,rchild;
    for(int i=0;i<n;i++){
        scanf("%*c%c %c",&lchild,&rchild);//输入左右孩子
        Node[i].lchild=strtonum(lchild);//左右孩子字符串转为数字
        Node[i].rchild=strtonum(rchild);
    }
    
    int root=findroot();//获得根节点
    postorder(root);
    bfs(root);
    num=0;//输出个数置零
    inorder(root);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值