7、【2】地铁修建 (选做)(图)
[问题描述]
A市有n个交通枢纽,其中1号和n号非常重要,为了加强运输能力,A市决定在1号到n号枢纽间修建一条地铁。
地铁由很多段隧道组成,每段隧道连接两个交通枢纽。经过勘探,有m段隧道作为候选,两个交通枢纽之间最多只有一条候选的隧道,没有隧道两端连接着同一个交通枢纽。
现在有n家隧道施工的公司,每段候选的隧道只能由一个公司施工,每家公司施工需要的天数一致。而每家公司最多只能修建一条候选隧道。所有公司同时开始施工。
作为项目负责人,你获得了候选隧道的信息,现在你可以按自己的想法选择一部分隧道进行施工,请问修建整条地铁最少需要多少天。
输入格式
输入的第一行包含两个整数n, m,用一个空格分隔,分别表示交通枢纽的数量和候选隧道的数量。
第2行到第m+1行,每行包含三个整数a, b, c,表示枢纽a和枢纽b之间可以修建一条隧道,需要的时间为c天。
[基本要求]
输出格式
输出一个整数,修建整条地铁线路最少需要的天数。
样例输入
6 6
1 2 4
2 3 4
3 6 7
1 4 2
4 5 5
5 6 6
样例输出
6
样例说明
可以修建的线路有两种。
第一种经过的枢纽依次为1, 2, 3, 6,所需要的时间分别是4, 4, 7,则整条地铁线需要7天修完;
第二种经过的枢纽依次为1, 4, 5, 6,所需要的时间分别是2, 5, 6,则整条地铁线需要6天修完。
第二种方案所用的天数更少。
#include<iostream>
#include<stdio.h>
#include<windows.h>
#include<fstream>
#include<map>
#include<set>
#include<queue>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<math.h>
#include<stdio.h>
#include<stdlib.h>
#include<stdbool.h>
#define OK 1
#define TRUE 1
#define FALSE 0
#define MAXSIZE 65536
using namespace std;
typedef int status;
typedef int Status;
typedef int ElemType;
typedef string DataType;
ElemType Tmp[MAXSIZE];
struct Map{ //地铁线路
int start; //起点
int end; //终点
int value; //权值
}Maps[MAXSIZE];
Status Compare(Map A, Map B){ //进行value的比较来递增
if (A.value < B.value)
return TRUE;
else
return FALSE;
}
Status Find(ElemType X){
int i;
if(Tmp[X] == X){
return X;
}
else{
Tmp[X] = Find(Tmp[X]); //递归
return Tmp[X];
}
}
int main() {
int n, m, min_val; //n 地点,m 数量,最少消耗
int a, b, c;
cin>>n>>m;
for (int i = 1; i <= n; i++) //
Tmp[i] = i;
for (int i = 0; i < m; i++){
cin>>Maps[i].start>>Maps[i].end>>Maps[i].value;
}
sort(Maps, Maps + m, Compare);
for (int i = 0; i < m; i++){
Tmp[Find(Maps[i].start)] = Find(Maps[i].end);
if (Find(1) == Find(n)) {
min_val = Maps[i].value;
break;
}
}
cout << min_val << endl;
return 0;
}