[Linux Debug]解决在RH8中安装gcc出现没法通过GPG验证的问题:软件包 glibc-devel-2.28-164.el8.x86_64 不能被验证,repo base 启用了 GPG

软件包 glibc-devel-2.28-164.el8.x86_64 不能被验证,repo base 启用了 GPG

以下是报错:

安装软件包失败: 软件包 glibc-devel-2.28-164.el8.x86_64 不能被验证,repo base 启用了 GPG: /var/cache/PackageKit/8.6/metadata/base-8-x86_64/packages/glibc-devel-2.28-164.el8.x86_64.rpm could not be verified.
/var/cache/PackageKit/8.6/metadata/base-8-x86_64/packages/glibc-devel-2.28-164.el8.x86_64.rpm: digest: SIGNATURE: 不正确

详细报错原文:

[lkh021@localhost exp01]$ gcc -o fork.out fork.cpp 
bash: gcc: 未找到命令...
安装软件包“gcc”以提供命令“gcc”? [N/y] y


 * 正在队列中等待... 
下列软件包必须删除:
 glibc-gconv-extra-2.28-189.1.el8.x86_64	All iconv converter modules for glibc.
下列软件包必须降级:
 glibc-2.28-164.el8.x86_64	The GNU libc libraries
 glibc-all-langpacks-2.28-164.el8.x86_64	All language packs for glibc.
 glibc-common-2.28-164.el8.x86_64	Common binaries and locale data for glibc
 glibc-langpack-en-2.28-164.el8.x86_64	Locale data for en
 glibc-langpack-zh-2.28-164.el8.x86_64	Locale data for zh
 libgomp-8.5.0-4.el8_5.x86_64	GCC OpenMP v4.5 shared support library
下列软件包必须安装:
 cpp-8.5.0-4.el8_5.x86_64	The C Preprocessor
 gcc-8.5.0-4.el8_5.x86_64	Various compilers (C, C++, Objective-C, ...)
 glibc-devel-2.28-164.el8.x86_64	Object files for development using standard C libraries.
 glibc-headers-2.28-164.el8.x86_64	Header files for development using standard C libraries.
 isl-0.16.1-6.el8.x86_64	Integer point manipulation library
 kernel-headers-4.18.0-348.7.1.el8_5.x86_64	Header files for the Linux kernel for use by glibc
 libxcrypt-devel-4.1.1-6.el8.x86_64	Development files for libxcrypt
继续更改? [N/y] y


 * 正在队列中等待... 
 * 正在等待认证... 
 * 正在队列中等待... 安装软件包失败: 软件包 glibc-devel-2.28-164.el8.x86_64 不能被验证,repo base 启用了 GPG: /var/cache/PackageKit/8.6/metadata/base-8-x86_64/packages/glibc-devel-2.28-164.el8.x86_64.rpm could not be verified.
/var/cache/PackageKit/8.6/metadata/base-8-x86_64/packages/glibc-devel-2.28-164.el8.x86_64.rpm:  digest:  SIGNATURE:  不正确

解决方案,使用yum来进行gcc的安装就可以进行GPG的验证了。

yum install gcc

使用yum的好处

yum是一种包管理器,用于在Linux系统上安装、更新和删除软件包。以下是yum的一些特点:

  • 自动解决依赖关系:当您安装软件包时,yum会自动检查并安装所需的依赖关系,以确保软件包能够正常运行。
  • 简单易用:yum提供了一个简单易用的命令行界面,使用户可以轻松地搜索、安装、更新和删除软件包。
  • 快速高效:yum使用缓存来加快软件包的下载和安装速度,同时还可以并行下载多个软件包,从而提高效率。
  • 安全可靠:yum使用GPG密钥来验证软件包的完整性和真实性,从而确保软件包没有被篡改或感染病毒。

使用gcc安装可能会出现的报错原文:

错误:
 问题: 软件包 gcc-8.5.0-4.el8_5.x86_64 需要 glibc-devel >= 2.2.90-12,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libpthread.so.0,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libdl.so.2,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libm.so.6,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libresolv.so.2,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 librt.so.1,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libBrokenLocale.so.1,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libanl.so.1,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libthread_db.so.1,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.i686 需要 libutil.so.1,但没有提供者可以被安装
  - 软件包 glibc-devel-2.28-164.el8.x86_64 需要 glibc = 2.28-164.el8,但没有提供者可以被安装
  - glibc-2.28-164.el8.i686 有 inferior 架构
  - 无法同时安装 glibc-2.28-164.el8.x86_64 和 glibc-2.28-189.1.el8.x86_64
  - 软件包 glibc-gconv-extra-2.28-189.1.el8.x86_64 需要 glibc(x86-64) = 2.28-189.1.el8,但没有提供者可以被安装
  - 无法为该任务安装最佳候选
  - 安装的软件包的问题 glibc-gconv-extra-2.28-189.1.el8.x86_64
(尝试在命令行中添加 '--allowerasing' 来替换冲突的软件包 或 '--skip-broken' 来跳过无法安装的软件包 或 '--nobest' 来不只使用软件包的最佳候选)

解决方案:尝试在命令行中添加 ‘–allowerasing’ 来替换冲突的软件包

yum install gcc --allowerasing
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

驼同学.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值