POJ 1387 Team Queue

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.
Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

Output

For each test case, first print a line saying “Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

思路

此处的队列需要在队列中间插入元素,所以不能用标准的队列结构。这里选用的是vector存储队列中的元素,vector可以在指定位置插入数据。我们要怎么判断主队中是否有分队相同的元素,遍历查找肯定是会超时的,这里引入一个数组记录每个分队中在主队中元素的个数,进去一个元素,数组对应值加一,相反,出去一个,值减一。除了要知道队伍中是否有同队,还有知道如果有同队,它的位置在哪。因为要在同队的后面插入,所以只需要知道分队的队尾元素位置,这里又引入了一个数组记录分队队尾元素的位置。这样就可以插入了,每插入一个记得更新队尾下标。但问题是此处插入一个元素,后面所有分队之前记录的下标就都不对了。怎么加一,是一个麻烦事。这里又用了两个数组记录分队的顺序来实现,就是有点麻烦。还有弹出队首元素之后,队首元素不能删除,因为如果删除了,就会导致后面的下标又乱了。所有采用记录队首下标的方法,需要删除队首时,将队首下标后移。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
									//tp存一个分队在主队尾元素的下标   ele存元素属于哪个分队 
int tp[1001],ele[1000001],tn[1001],qo[1001],qq[1001];//tn存一个分队有多少元素在主队 qo存主队第i个分队是哪个分队 
vector<int>q;									//总队列 							qq存某个分队在主队中的位置 

int main()
{
	int num=0,t;
	while(1)
	{
		cin>>t;
		if(t==0)
			return 0;
		num++;										//记录测试编号 
		memset(tp,0,sizeof(tp));					//重置数据 
		memset(ele,0,sizeof(ele));
		memset(tn,0,sizeof(tn));
		q.clear();
		int st=0;									//主队队首下标 
		for(int i=1;i<=t;i++)
		{
			int n,a;
			scanf("%d",&n);
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&a);						//读入数据 
				ele[a]=i;							//记录是哪个分队的 
			}
		}
		printf("Scenario #%d\n",num);
		char s[101];
		int m,nn=0;									//nn记录主队中的分队次序 
		while(1)
		{
			cin>>s;
			if(s[0]=='E')							//判断首字母 
			{
				scanf("%d",&m);
				if(tn[ele[m]])						//如果该元素所属分队个数不为零,则插入 
				{
					tn[ele[m]]++;					//分队中个数加一 
					q.insert(q.begin()+tp[ele[m]]+1,m);	//插入 
					for(int i=qq[ele[m]];i<nn;i++)	//由于此处插入,后面的所有分队队尾元素下标加一 
						tp[qo[i]]++;
				}
				else
				{
					tn[ele[m]]++;					//个数加一 
					q.push_back(m);					//队尾插入 
					tp[ele[m]]=q.size()-1;			//队尾插入,下标为总元素个数减一 
					qq[ele[m]]=nn;					//记录该分队是总队中的第几个 
					qo[nn]=ele[m];					//记录主队中的第n个对是它		 
					nn++;							//这两处记录都是为了上一条if中的所有分队队尾下标后移 
				}									//    因为不知道后面有哪些分队,所以此处引入两个数组记录 
			}
			if(s[0]=='D')
			{
				int b=q[st];						//读出首元素 
				st++;								//队首元素无法删除  所以只能队首下标加一 
				printf("%d\n",b);
				tn[ele[b]]--;						//分队在主队中的个数减一 
			}
			if(s[0]=='S')
			{
				printf("\n");						//!!!别忘空行 
				break;
			}
		}
	}
} 
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值