Root of AVL Tree

4 篇文章 0 订阅

description

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在这里插入图片描述

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88

思路

按照输入的顺序建一棵平衡二叉树,输出树的根

代码

#include<iostream>
#include<cstdlib> 
using namespace std;

typedef struct AVLNode* AVLTree;
typedef int ElementType;
struct AVLNode {
	ElementType data;
	AVLTree left;
	AVLTree right;
	int height;
};

int GetHeight(AVLTree bt)
{
	if(bt)
		return max(GetHeight(bt->left),GetHeight(bt->right))+1;
	return 0;
}

AVLTree LeftRotation(AVLTree a)
{
	AVLTree b=a->left;
	a->left=b->right;
	b->right=a;
	a->height=max(GetHeight(a->left),GetHeight(a->right))+1;
	b->height=max(GetHeight(b->left),a->height)+1;
	return b;
}

AVLTree RightRotation(AVLTree a)
{
	AVLTree b=a->right;
	a->right=b->left;
	b->left=a;
	a->height=max(GetHeight(a->left),GetHeight(a->right))+1;
	b->height=max(a->height,GetHeight(b->right))+1;
	return b;
}

AVLTree LeftRightRotation(AVLTree a)
{
	a->left=RightRotation(a->left);
	return LeftRotation(a);
}

AVLTree RightLeftRotation(AVLTree a)
{
	a->right=LeftRotation(a->right);
	return RightRotation(a);
}

AVLTree Insert(AVLTree t, ElementType x)
{
	if (!t)
	{
		t = (AVLTree)malloc(sizeof(AVLNode));
		t->data = x;
		t->height = 0;
		t->left = t->right = NULL;
	}
	else if (x < t->data)									//插入左子树 
	{
		t->left = Insert(t->left, x);
		if(GetHeight(t->left)-GetHeight(t->right)==2)
		{
			if (x < t->left->data)							//LL
				t = LeftRotation(t);
			else											//LR
			//!!!此处写 else if (x > t->right->data) 提示可能是数组越界,堆栈溢出(比如,递归调用层数太多)等情况引起 
			//没搞懂  
				t = LeftRightRotation(t);
		}
	}
	else if (x > t->data)									//插入右子树
	{
		t->right = Insert(t->right, x);
		if(GetHeight(t->right)-GetHeight(t->left)==2)
		{
			if (x < t->right->data)							//Rl
				t = RightLeftRotation(t);
			else											//RR
				t = RightRotation(t);
		}
	}
	//相等都不用管
	t->height=max(GetHeight(t->left),GetHeight(t->right))+1;
	return t;
}

int main()
{
	int n, x;
	cin >> n;
	AVLTree t=NULL;											//注意初始化t为NULL 
	for (int i = 1; i <= n; i++)
	{
		cin >> x;
		t = Insert(t, x);
	}
	if(t)
		cout << t->data;
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值