POJ 3157 Java vs C++(字符串)

Description

Apologists of Java and C++ can argue for hours proving each other that their programming language is the best one. Java people will tell that their programs are clearer and less prone to errors, while C++ people will laugh at their inability to instantiate an array of generics or tell them that their programs are slow and have long source code.

Another issue that Java and C++ people could never agree on is identifier naming. In Java a multiword identifier is constructed in the following manner: the first word is written starting from the small letter, and the following ones are written starting from the capital letter, no separators are used. All other letters are small. Examples of a Java identifier are javaIdentifier, longAndMnemonicIdentifier, name, nEERC.

Unlike them, C++ people use only small letters in their identifiers. To separate words they use underscore character ‘_’. Examples of C++ identifiers are c_identifier, long_and_mnemonic_identifier, name (you see that when there is just one word Java and C++ people agree), n_e_e_r_c.

You are writing a translator that is intended to translate C++ programs to Java and vice versa. Of course, identifiers in the translated program must be formatted due to its language rules — otherwise people will never like your translator.

The first thing you would like to write is an identifier translation routine. Given an identifier, it would detect whether it is Java identifier or C++ identifier and translate it to another dialect. If it is neither, then your routine should report an error. Translation must preserve the order of words and must only change the case of letters and/or add/remove underscores.

Input

The input file consists of one line that contains an identifier. It consists of letters of the English alphabet and underscores. Its length does not exceed 100.

Output

If the input identifier is Java identifier, output its C++ version. If it is C++ identifier, output its Java version. If it is none, output “Error! instead.

Sample

Sample Input

sample input #1
long_and_mnemonic_identifier

sample input #2
anotherExample

sample input #3
i

sample input #4
bad_Style
Sample Output

sample output #1
longAndMnemonicIdentifier

sample output #2
another_example

sample output #3
i

sample output #4
Error!

思路

简单的字符串转换,边读边输出,转换成C++的是,跳过下划线将下一个字母转换成大写;转换成Java的是,读到大写,先输出一个下划线,然后将大写转换成小写。但有些地方太坑了。
以下几个地方注意:

  • 不能同时出现大写和下划线
  • 首位不能大写
  • 首位和末尾不能是下划线
  • 不能有两个连续的下划线

代码

#include<iostream>
#include<string>
using namespace std;

int main()
{
	string s;
	cin>>s;
	int java=0,C=0;
	bool flag=0;
	if(s[0]>='A'&&s[0]<='Z')
		flag=1;
	if(s[s.length()-1]=='_'||s[0]=='_')
		flag=1;
	for(int i=0;i<s.length()&&!flag;i++)
	{
		if(s[i]=='_')
		{
			java++;
			if(s[i+1]=='_')
				flag=1;
		}	
		if(s[i]>='A'&&s[i]<='Z')
			C++;	
	}
	if((java&&C)||flag)
	{
		cout<<"Error!";
		return 0;
	}
	if(!java&&!C)
	{
		cout<<s;
		return 0;
	}
	if(java)
	{
		for(int i=0;i<s.length();i++)
		{
			if(s[i]>='a'&&s[i]<='z')
				cout<<s[i];
			else
				cout<<(char)(s[++i]+'A'-'a');
		}
		return 0;
	}
	for(int i=0;i<s.length();i++)
	{
		if(s[i]>='a'&&s[i]<='z')
			cout<<s[i];
		else
			cout<<"_"<<(char)(s[i]+'a'-'A');
	}
	return 0;	
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值