中序遍历和前序遍历还原层序遍历

L2-011 玩转二叉树 (25 分)

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

类型:bfs、树的重建和还原

思路:划分左右区间,bfs层序遍历。

代码:

#include <bits/stdc++.h>
#define int long long
using namespace std;
const int N = 1e5+10;
struct node{
	int l, r;
}tree[200];
int pre[50], in[50];
int root ;
int build(int l1, int r1, int l2, int r2)
{
	if(l1 > r1 || l2 > r2) return -1; 
	int pos ; 
	for(pos = l1; pos <= r1; pos++) if(pre[l2] == in[pos])break;
    
    int rt = pre[l2];
	tree[rt].l = build(l1, pos-1, l2+1, l2+(pos - l1));
	tree[rt].r = build(pos+1, r1, l2+1+(pos - l1), r2);
	return rt;
}
void bfs()
{
	queue < int > q;
	q.push(root);
    int cnt = 1;
	while(q.size())
	{
		int x = q.front();
		q.pop(); 
		if(cnt == 1) cout<<x;
        else cout<<' '<<x;
        cnt++;
		if(tree[x].r != -1){
			q.push(tree[x].r);
		}
		if(tree[x].l != -1){
			q.push(tree[x].l);
		}  
	}
	cout<<endl;
}
signed main()
{
	int n;
	cin>>n;
	memset(tree, -1 , sizeof(tree));
	for(int i = 1; i<= n; i++) cin>>in[i];
	for(int i = 1; i<= n; i++) cin>>pre[i];
	root = pre[1];
	build(1, n, 1, n);
	bfs(); 
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值