PTA L2-011 玩转二叉树

文章描述了如何根据给定的二叉树的中序遍历和前序遍历,首先进行镜面反转操作,然后输出反转后的层序遍历序列。给出了一个使用C++实现的示例代码,展示了从输入序列构建二叉树、反转树结构以及获取层序遍历的过程。
摘要由CSDN通过智能技术生成

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>

using namespace std;

const int N = 35;

struct Node
{
    int val;
    struct Node* lchild;
    struct Node* rchild;
}a[N];
int id;

int pre[N],in[N];

Node* build_tree(int in[],int inl,int inr,int pre[],int prel,int prer)
{
    if(inl > inr) return NULL;
    Node* root = &a[id++];
    root->val = pre[prel];
    int tmp = 0;
    for(tmp = inl;in[tmp] != pre[prel];tmp++);
    
    root->lchild = build_tree(in,inl,tmp - 1,pre,prel + 1,prel + tmp - inl);
    root->rchild = build_tree(in,tmp + 1,inr,pre,prel + tmp - inl + 1,prer);

    return root;
}

void test(Node* root)//测试用
{
    if(!root) return;
    cout << root->val << " ";
    test(root->lchild);
    test(root->rchild);
}

void tree_reverse(Node* root)
{
    if(root == NULL) return;
    tree_reverse(root->lchild);
    tree_reverse(root->rchild);
    swap(root->lchild,root->rchild);
}

void order_level(Node* root)
{
    if(root == NULL) return;
    queue<Node*> q;
    q.push(root);
    int flag = 0;
    while(q.size())
    {
        Node* t = q.front();
        q.pop();
        
        if(flag) cout << " ";
        cout << t->val;
        flag = 1;
        if(t->lchild) q.push(t->lchild);
        if(t->rchild) q.push(t->rchild);
    }
}
int main()
{
    int n = 0;
    cin >> n;
    for(int i = 0;i < n;i++) cin >> in[i];
    for(int i = 0;i < n;i++) cin >> pre[i];

    Node* root  = build_tree(in,0,n - 1,pre,0,n - 1);
    tree_reverse(root);
    // test(root);
    order_level(root);
    return 0;
}

注:

 不会的可以借鉴这个视频的方法。

L2-006 树的遍历 (25 分)_哔哩哔哩_bilibili

结果:

 

  • 13
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值