HDU 3530 Subsequence(单调队列)

题目链接:Problem - 3530 (hdu.edu.cn)

Problem Description

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.

Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

Output

For each test case, print the length of the subsequence on a single line.

Sample Input

 

5 0 0

1 1 1 1 1

5 0 3

1 2 3 4 5

Sample Output

 

5

4

思路:这题用单调队列可以实现,遍历一遍数组然后创建两个两个单调队列去维护到遍历位置的递增,递减区间,然后判断最大值和最小值的差值是否是大于等于m,小于等于k的,如果大于k了就找第二值或者第二小值,抛弃到最靠前的那一个

#include<bits/stdc++.h>
using namespace std;

int arr[200005]; //题目的数组 
int a[200005]; //单调递减队列 
int b[200005]; //单调递增队列 

int main(){
	int n, m, k;
	while(cin >> n >> m >> k){
		for(int i = 1; i <= n; i++){
			cin >> arr[i];
		}
		int ah = 1, at = 0;
		int bh = 1, bt = 0;
		int ans = 0, l = 0;
		for(int i = 1; i <= n; i++){
			while(ah <= at && arr[a[at]] < arr[i]){
				at--;
			}
			a[++at] = i;
			while(bh <= bt && arr[b[bt]] > arr[i]){
				bt--;
			}
			b[++bt] = i;
			while(ah <= at && bh <= bt && arr[a[ah]] - arr[b[bh]] > k){
				//用来抛弃掉首位 
				if(a[ah] > b[bh]){
					l = b[bh++];
				}else{
					l = a[ah++];
				}
			}
			if(arr[a[ah]] - arr[b[bh]] <= k && arr[a[ah]] - arr[b[bh]] >= m){
				//在满足条件的区间找一个最大值 
				ans = max(ans, i - l);
			}
 		} 
 		cout << ans << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值