hdu 3530 Subsequence 单调队列 求最长连续区间,满足条件(m<=max-min<=k)

这是一篇关于如何利用单调队列解决HDU 3530题目的文章,该题目要求找到满足特定条件(m <= max - min <= k)的最长连续子序列。文章将详细阐述算法思路和实现过程。
摘要由CSDN通过智能技术生成

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 734    Accepted Submission(s): 277

Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

 

Output
For each test case, print the length of the subsequence on a single line.
 

 

Sample Input
  
  
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

 

Sample Output
  
  
5 4
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int f[100005],p[100005],q[100005],p1,p2,q1,q2,now,n,m,k,i,ans;
int main()
{
 while(scanf("%d%d%d",&n,&m,&k)==3)
 {
     memset(p,0,sizeof(p));
     memset(q,0,sizeof(q));
  p1=q1=q2=p2=now=ans=0;
  for (i=0;i<n;i++) scanf("%d",&f[i]);
  for (i=0;i<n;i++)
  {
   while(p2>=1&&f[i]<=f[p[p2-1]]&&p1<p2) p2--;p[p2++]=i;
   while(q2>=1&&f[i]>=f[q[q2-1]]&&q1<q2) q2--;q[q2++]=i;
   while(f[q[q1]]-f[p[p1]]>k) if (p[p1]<q[q1]) {now=p[p1]+1;p1++;}else {now=q[q1]+1;q1++;}
   if (f[q[q1]]-f[p[p1]]<=k&&f[q[q1]]-f[p[p1]]>=m) if (i-now+1>ans) ans=i-now+1;
  }
  printf("%d/n",ans);
 }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值