PAT甲级1005 Spell It Right(拼写正确)详细题解C++

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

给定一个非负整数N,你的任务是计算N的所有数字的总和,并以英语输出总和的每个数字。

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10^{100}).

共一行,包含一个整数N。(N≤10^{100})

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

共一行,用英语输出总和的每个数字,单词之间用空格隔开。

Sample Input:

12345

Sample Output:

one five

代码长度限制 16 KB 时间限制 400 ms 内存限制 64 MB

解析

对于本题,我们可以先输入一个字符串数组,然后将其每一位的数字进行累加,得出总和,再将总和按位转换为英文单词。(要注意的是由于数值范围过大,所以输入不能采用数值类型,即使是longlong类型也会超出范围。)

首先我们定义一个字符串数组用来存放英文单词:

string word_list[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};

然后我们输入数值num,同时对num=0的情况进行特殊判断,防止报错:

string num;
    int sum;
    cin>>num;
    if(num=="0") {
        cout<<"zero";
        return 0;
    }

之后我们通过一个for循环,计算所有位的累加和:

for(int i=0;i<num.size();i++){
        sum+=num[i]-'0';
    }

我们定义一个数组n,将累加和按位分割成数字后存入n中:

int n[100],j=0;
    while (sum!=0)
    {
        n[j]=sum%10;
        j++;
        sum/=10;
    }
    j--;//多出来一位,需要减去

最后按照数值寻找对应的英文单词进行输出:

while(j){
        cout<<word_list[n[j]]<<" ";
        j--;
    }
    cout<<word_list[n[j]];
    return 0;

完整代码

#include<bits/stdc++.h>
using namespace std;
string word_list[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main(){
    string num;
    int sum;
    cin>>num;
    if(num=="0") {
        cout<<"zero";
        return 0;
    }
    for(int i=0;i<num.size();i++){
        sum+=num[i]-'0';
    }
    int n[100],j=0;
    while (sum!=0)
    {
        n[j]=sum%10;
        j++;
        sum/=10;
    }
    j--;
    while(j){
        cout<<word_list[n[j]]<<" ";
        j--;
    }
    cout<<word_list[n[j]];
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值