PAT甲级真题-C++-To Buy or Not to Buy

To Buy or Not to Buy

-->练习此题<--

题目描述:

Eva would like to make a string of beads with her favorite colors so shewent to a small shop to buy some beads.

There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces.

Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help:
if the answer is “Yes”, please tell her the number of extra beads she has to buy; or if the answer is “No”, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors.
For example, the string “YrR8RrY” is the one that Eva would like to make. Then the string “ppRYYGrrYBR2258” is okay since it contains all the necessary beads with 8 extra ones;
yet the string “ppRYYGrrYB225” is not since there is no black bead and one less red bead.

输入描述:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

输出描述:

For each test case, print your answer in one line. If the answer is “Yes”, then also output the number of extra beads Eva has to buy; or if the answer is “No”, then also output the number of beads missing from the string. There must be exactly 1 space between the answer
and the number.

输入样例:

ppRYYGrrYBR2258
YrR8RrY

输出样例:

Yes 8

本人AC代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
    ios::sync_with_stdio(false);
    cout.tie(0);
    string s1;
    string s2;
    getline(cin,s1);
    getline(cin,s2);
    int m=s1.size();
    int n=s2.size();
    unordered_map<char,int> map;
    int ans=0;
    for(int i=0;i<m;i++){
        map[s1[i]]++;
    }
    for(int i=0;i<n;i++){
        if(map.find(s2[i])!=map.end()&&map[s2[i]]>0){
            map[s2[i]]--;
        }
        else ans++;
    }
    if(ans==0){
        cout<<"Yes "<<m-n<<endl;
    }
    else{
        cout<<"No "<<ans<<endl;
    }
    return 0;
}

声明:不保证代码健壮性,只确保通过顶部链接练习网站所提供测试案例;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值