PAT甲级真题-C++-Path of Equal Weight

Path of Equal Weight

-->练习此题<--

题目描述:

Given a non-empty tree with root R, and with weight Wi
assigned to each tree node Ti
. The weight of a path from R to L
is defined to be the sum of the weights of all the nodes along the path
from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with
their weights equal to a given number. For example, let’s consider the
tree showed in Figure 1: for each node, the upper number is the node ID
which is a two-digit number, and the lower number is the weight of that
node. Suppose that the given number is 24, then there exists 4
different paths which have the same given weight: {10 5 2 7}, {10 4 10},
{10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in
Figure 1.
在这里插入图片描述
Figure 1

输入描述:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

输出描述:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1, A2, …, An} is said to be greater than sequence {B1, B2, …, Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, … k, and Ak+1 > Bk+1.

输入样例:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

输出样例:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

本人AC代码:

#include<bits/stdc++.h>
using namespace std;

struct TreeNode{
    int val;
    vector<TreeNode*> son;
    TreeNode(int x):val(x),son({}){}
};

void sortByVal(TreeNode* root){
    int n=root->son.size();
    for(int i=0;i<n-1;i++){
        int loc=i;
        for(int j=i;j<n;j++){
            if(root->son[j]>root->son[loc]){
                loc=j;
            }
        }
        swap(root->son[i],root->son[loc]);
    }
}

void dfs(TreeNode* root,vector<vector<int>>& ans,vector<int> an,int target){
    an.push_back(root->val);
    target-=root->val;
    int n=root->son.size();
    if(n==0&&target==0) ans.push_back(an);
    else{
        for(int i=0;i<n;i++){
            dfs(root->son[i],ans,an,target);
        }
    }
}

int main(){
    int target;
    int n;
    int ran;
    cin>>n>>ran>>target;
    vector<TreeNode*> nodes(n);
    for(int i=0;i<n;i++){
        int val;
        cin>>val;
        TreeNode* node=new TreeNode(val);
        nodes[i]=node;
    }
    for(int i=0;i<ran;i++){
        int ser;
        int num;
        cin>>ser>>num;
        for(int i=0;i<num;i++){
            int sonser;
            cin>>sonser;
            nodes[ser]->son.push_back(nodes[sonser]);
        }
        sortByVal(nodes[ser]);
    }
    vector<vector<int>> ans;
    vector<int> an;
    dfs(nodes[0],ans,an,target);
    int m=ans.size();
    for(int i=0;i<m;i++){
        int k=ans[i].size();
        for(int j=0;j<k;j++){
            cout<<ans[i][j]<<" ";
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值