UVA-133 The Dole Queue 救济金发放

一、题目

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0)

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma). Note: The symbol ⊔ in the Sample Output below represents a space.

Sample Input

10 4 3

0 0 0

Sample Output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣

二、分析

题意是n个人逆时针绕一圈排列,先从0开始按逆时针方向数k个人,第k个人出列,再从0开始顺时针数m个人,第m个人出列。重复逆时针数k个人、顺时针数m个人,直至所有人出列。

题目中样例输出的符号是空格,输出时只需要%3d控制占位即可。

本题循环的重要部分就是要让位置下标在合理的范围内操作,p1=(p1+n)%n+1;//逆时针;p2=(p2+n-2)%n+1;//顺时针。

#include<stdio.h>
#include<string.h>
int main()
{
	int a[30];
	int n,k,m;
	while(scanf("%d%d%d",&n,&k,&m))
	{
		memset(a,0,sizeof(a));
		if(n==0&&k==0&&m==0) break;
		int ans=n;
		int p1=n,p2=1;
		while(ans)
		{
			int k1=k,m1=m;
			while(k1--){
				p1=(p1+n)%n+1;//逆时针
				if(a[p1]) k1++;
			}
			while(m1--){//顺时针
				p2=(p2+n-2)%n+1;
				if(a[p2]) m1++;
			}
			printf("%3d",p1);ans--;
			if(p1!=p2){
				printf("%3d",p2);
				ans--;
			}
			a[p1]=1;a[p2]=1;
			if(ans!=0) printf(",");
			else printf("\n");
		}
	}
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值