在猜数列游戏1的基础上,按顺序循环提供6个不同的数列,每次按顺序给出其中一个数列的连续两个数,再要求用户作答。6个数列大小不固定,即每个数列大小不局限于8个数,可能是10个,100个,1000个数:
- 1:Fibonacci:1,1,2,3,5,8,13,21
- 2:Lucas:1,3,4,7,11,18,29,47
- 3:Pell:1,2,5,12,29,70,169,408
- 4:Triangular:1,3,6,10,15,21,28,36
- 5:Square:1,4,9,16,25,36,49,64
- 6:Pentagonal:1,5,12,22,35,51,70,92
输入格式:
根据提示输入整数数值或Y或N
输出格式:
与猜数列游戏1要求一致。
输入样例:
在这里给出一组输入。例如:
2
Y
4
Y
5
Y
6
Y
9
Y
12
Y
3
Y
7
Y
12
Y
10
Y
16
Y
22
Y
5
Y
11
Y
29
N
输出样例:
在这里给出相应的输出。例如:
The first 2 value is 1,1.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,3.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,2.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,3.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,4.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,5.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,2.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 3,4.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 2,5.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 3,6.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 4,9.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 5,12.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 2,3.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 4,7.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 5,12.What is the next value?
Want to try another sequence?(Y/N)
num_of_rights:15 num_of_tries:15
代码实现(C++)
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int a1=3,a2=5,i=0,num,sum_t=0,sum_Y=0;
int h[6][10]={{1,1,2,3,5,8,13,21},{1,3,4,7,11,18,29,47},{1,2,5,12,29,70,169,408},{1,3,6,10,15,21,28,36},{1,4,9,16,25,36,49,64},{1,5,12,22,35,51,70,92}};
int count=0;
int a[6]={0};
char ch,ch2;
bool go1=true,go2=true;
while(1)
{
if(i<1)
{
cout << "The first 2 value is " << h[count][a[count]] << ',' << h[count][a[count]+1] << ".What is the next value?" << endl;
}
i++;
if(i<=100&&i>=1)
cin >> num;
while(1)
{
if(num!=h[count][a[count]+2]&&i==1)
{
printf("Nice guess but not quite it.\n");
sum_t++;
}
if(num!=h[count][a[count]+2]&&i==2)
{
printf("Wrong a second time.\n");
sum_t++;
}
if(num!=h[count][a[count]+2]&&i==3)
{
printf("This is harder than it looks.\n");
sum_t++;
}
if(num!=h[count][a[count]+2]&&i==4)
{
sum_t++;
printf("It must be getting pretty frustrating by now!\n");
}
if(num!=h[count][a[count]+2])
{
printf("Do you want to guess again?\n");
cin >> ch2;
if(ch2=='Y')
{
break;
}
}
if(num == h[count][a[count]+2]||ch2=='N')
{
i=0;
if(num==h[count][a[count]+2])
{
sum_Y++;
sum_t++;
}
printf("Want to try another sequence?(Y/N)\n");
switch(count)
{
case 0:
if(a[count]<7) a[count]++;
else a[count]=0; break;
case 1:
if(a[count]<7) a[count]++;
else a[count]=0; break;
case 2:
if(a[count]<7) a[count]++;
else a[count]=0; break;
case 3:
if(a[count]<7) a[count]++;
else a[count]=0; break;
case 4:
if(a[count]<7) a[count]++;
else a[count]=0; break;
case 5:
if(a[count]<7) a[count]++;
else a[count]=0; break;
}
count++;
if(count>5)
count=0;
cin >> ch;
if(ch == 'Y')
break;
else
{
printf("num_of_rights:%d num_of_tries:%d",sum_Y,sum_t);
exit(0);
}
}
}
}
return 0;
}