The Cow Prom POJ 3180

传送门
The N (2 <= N <= 10,000) cows are so excited: it’s prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round Dance.

Only cows can perform the Round Dance which requires a set of ropes and a circular stock tank. To begin, the cows line up around a circular stock tank and number themselves in clockwise order consecutively from 1…N. Each cow faces the tank so she can see the other dancers.

They then acquire a total of M (2 <= M <= 50,000) ropes all of which are distributed to the cows who hold them in their hooves. Each cow hopes to be given one or more ropes to hold in both her left and right hooves; some cows might be disappointed.

For the Round Dance to succeed for any given cow (say, Bessie), the ropes that she holds must be configured just right. To know if Bessie’s dance is successful, one must examine the set of cows holding the other ends of her ropes (if she has any), along with the cows holding the other ends of any ropes they hold, etc. When Bessie dances clockwise around the tank, she must instantly pull all the other cows in her group around clockwise, too. Likewise,
if she dances the other way, she must instantly pull the entire group counterclockwise (anti-clockwise in British English).

Of course, if the ropes are not properly distributed then a set of cows might not form a proper dance group and thus can not succeed at the Round Dance. One way this happens is when only one rope connects two cows. One cow could pull the other in one direction, but could not pull the other direction (since pushing ropes is well-known to be fruitless). Note that the cows must Dance in lock-step: a dangling cow (perhaps with just one rope) that is eventually pulled along disqualifies a group from properly performing the Round Dance since she is not immediately pulled into lockstep with the rest.

Given the ropes and their distribution to cows, how many groups of cows can properly perform the Round Dance? Note that a set of ropes and cows might wrap many times around the stock tank.
Input
Line 1: Two space-separated integers: N and M

Lines 2…M+1: Each line contains two space-separated integers A and B that describe a rope from cow A to cow B in the clockwise direction.
Output
Line 1: A single line with a single integer that is the number of groups successfully dancing the Round Dance.
Sample Input
5 4
2 4
3 5
1 2
4 1
Sample Output
1

题意: 有编号为1-N的牛,给出M组有向连接,求有多少个连接数大于1的闭环。

题解:实际上就是求大于1的强连通分量个数,我这里用的是Kosaraju 算法。

#include<iostream>
#include<vector>
#include<cstring>
using namespace std;

vector<int>k1[1000001];
vector<int>k2[1000001];
int vis[1000101];
int num[1000101];
int df[1000101];
int n,m,k;

void dfs1(int x)
{
	vis[x]=1;
	
	for(int i=0;i<k1[x].size();i++)
	{
		int z=k1[x][i];
		if(vis[z]==0)
		dfs1(z);
	}
	
	num[k++]=x;
}

void dfs2(int x)
{
	vis[x]=1;
	df[x]=k;
	
	for(int i=0;i<k2[x].size();i++)
	{
		int z=k2[x][i];
		if(vis[z]==0)
		dfs2(z);
	}
	
}

int main()
{
	ios::sync_with_stdio(false);//cin 快速读入 减少用时
	
	while(cin>>n>>m)
	{
		for(int i=1;i<=n;i++)
		k1[i].clear(),k2[i].clear();
		
		for(int i=0;i<m;i++)
		{
			int x,y;
			cin>>x>>y;
			k1[x].push_back(y);
			k2[y].push_back(x);
		}
		
		memset(vis,0,sizeof(vis));
		k=1;
		
		for(int i=1;i<=n;i++)
		{
			if(vis[i]==0)
			dfs1(i);
		}
		
		k=0;
		memset(vis,0,sizeof(vis));
		
		for(int i=n;i>=1;i--)
		{
			if(vis[num[i]]==0)
			{
				k++;
				dfs2(num[i]);
			}
		}
		
		int mark[100010];
		
		for(int i=1;i<=n;i++)
		mark[df[i]]++;
		
		int ans=0;
		
		for(int i=1;i<=k;i++)
		{
			if(mark[i]>1)
			ans++;
		}
		
		cout<<ans<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值